Ubuntu 13.10 image doesn't seem to enable ethernet - should it?

I have written a Ubuntu image to my 32Gb micro SD card, it's the one
contained in ubuntu-13.10-console-armhf-2014-02-16.tar.xz. I used the
script that comes from the tar file to write the files to the micro SD
and it all seemed to work OK.

However although it *seems* to boot OK from the micro SD I can't
connect to the BBB using ssh as I can if I boot from the default
Angstrom Linux in the emmc.

Should this work or doesn't the Ubuntu image enable the ethernet? Or
doesn't it do a proper search for DHCP server etc.?

I don't really want to have to fire up the whole 'local user' side of
the BBB (mini HDMI, keyboard, mouse, etc.) just to get it working for
remote command line use as it's the remote command line I will always
be using in practice.

It's setup to get an ip from an dhcp.. So try..

ssh ubuntu@arm
ssh ubuntu@arm.local

ssh ubuntu@

or look at your router and find the ip it was given..

On first boot it can take up to a minute as the ssh keys are generated.


It's not appearing on my network at all, I use nscan or arp-scan to
see what's there as I have quite a lot of things (like a Raspberry Pi,
an Onkyo receiver and some printers) which aren't always that easy to

I'm beginning to think I may have a bad micro SD card because it came
back with some errors when I tried to read it using the card reader on
my desktop system.

I've ordered some new micro SD cards which will hopefully arrive
tomorrow, this can wait until then.

First try dd'ing this image to the microSD:


Just to be safe, hold down the boot button before poweron..

After a minute or so, try ssh'ing...

If that still doesn't work, I'd stick a usb-serial adapter on it..


cl@isbd.net wrote: