Ubuntu 14.4

Dear All;
Is there anybody knows the reason of not to be able to connect to Ubuntu 14.04 as ROOT via SSH (Putty) running on BeagleBone Black?
I did it at 13.04 and I can connect as root with root password. However I cannot manage it in 14.04.
How can I enable it at 14.04?

Cagri Yilmaz

Did you create a root user?
Did you enable the new openssh-server permission that disables root
access over ssh?


I did:

  1. After logged on user name ubuntu and password as temppwd
  2. sudo su entering the password as temppwd
  3. passwd twice.

After that I edited /etc/ssh/sshd_config

I added
PermitRootLogin yes

Restarted the service.

I did it at 13.04 like that and it used to work.
Anyway I will try to create the user called root.

Thank you very much for your support.

Best Regards,

Cagri Yilmaz

$ sudo passwd root        //creates a passwd for root.
$ sudo passwd -u root     // Unlocks the root account.

[https://www.google.com/#q=Ubuntu+enable+root](https://www.google.com/#q=Ubuntu+enable+root) -> [http://askubuntu.com/questions/44418/how-to-enable-root-login](http://askubuntu.com/questions/44418/how-to-enable-root-login)

Thanks William.

If you BBB is exposed to the internet, you should very seriously learn how to use sudo, and lock your root account.