Ubuntu Beagleboard-xm

I am trying to run Ubuntu on the beagleboard-xm.

When I run the script for Maverick, I get an error that says --align is not a recognized argument of parted, and the usage for parted. Is there a way to remedy this?

Then, I tried to do a manual setup of the SD card, but am struggling with this part:
U-Boot needs a compatible kernel image to boot. To do this, we are using mkimage from (uboot-mkimage) to create an image from the vmlinuz kernel file.

mkimage -A arm -O linux -T kernel -C none -a 0x80008000 -e 0x80008000 -n "Linux" -d ./vmlinuz-* ./uImage

I get an error message that states:
"mkimage: Can't open ./vmlinuz-*: No such file or directory"

How can I solve this problem?

Thanks for your help,

I have the same error message when running the demo script from the
elinux/beagleboardubuntu website. What needs to be done to fix the --
align isnot a recognized argument of parted?

I'm sorry, there is just not enough info ^^^ to help the writer of the
above script..

Can you paste the actual full messages? Otherwise i can't help you...

also enable "--fdisk-debug" at it will print more info to the screen...

and the result of "parted -v"


Robert thanks for looking. I didn't realize how vague I the question
was. There was an error with the script from http://elinux.org/BeagleBoardUbuntu#Natty_11.04
using the demo install. The version of parted I had gave an error of
"do not understand the option --align" . Turns out I needed to update
my machine. I was still on 9.10 Ubuntu (don't laugh). So I upgraded to
10.04 LTS and ran the script again with no problems. Thanks for the