Ubuntu Distribution : SSH & Com Port closed ?

Hi ,

I followed this tutorial : http://elinux.org/BeagleBoardUbuntu#Demo_Image to install ubuntu on my beaglebone Black.

I used this image : wget http://rcn-ee.net/deb/rootfs/raring/ubuntu-13.04-console-armhf-2013-05-29.tar.xz

And I installed my sdcard with this command : sudo ./setup_sdcard.sh --mmc /dev/sdX --uboot bone_dtb

The BBB start correctly, I can see on my LCD4 screen the linux logo and the default main screen : Ubuntu 13.04 arm tty1 … arm login:

My problem now, is how the hell can I connect to it ?

  • With the usb cable, I’m able to ping this address: http://192.168.7.2/ but with ssh it’s not possible … =>
  • ssh: connect to host 192.168.7.2 port 22: Connection timed out- With the ethernet cable, I’m able to ping the BBB ( I modified the file /etc/network/interfaces with my PC ) . But ssh gives me :
  • ssh: connect to host 190.190.167.2 port 22: Connection timed out- And for the last time, I tried with the COM port ( in my case : gadget serial COM5 ) with the baudrate 115200 … nothing, impossible to connect !!

I really don’t know what to do now …

Micka,

Okay,

I used an another image: http://www.armhf.com/index.php/boards/beaglebone-black/

And now, it’s working ^^

Hello,

I just ran into the same issue that image of Raring on my Beagleboard xM. It appears that sshd fails to start because the package isn’t configured correctly in the image. I was able to login through the LCD display I have hooked up, and I once I ran updates it ran the sshd configuration step and it worked fine after that. At least sshd did, I haven’t tested the serial port.

-Michael

Just finishing up final testing, new images will be uploaded today.
I'd normally post a link to my pending page, but that would take all
my bandwidth away for uploading the new images for everyone else..

So, just grab the 'previous' image,
http://rcn-ee.net/deb/rootfs/raring/

Regards,