Ubuntu oneiric rcn-ee.net r3 with gst-dsp and dsp-bridge error

Hello,

I've installed Ubuntu oneiric in my beagleboard using the steps in
http://elinux.org/BeagleBoardUbuntu, using
http://rcn-ee.net/deb/rootfs/oneiric/ubuntu-11.10-r3-minimal-armel.tar.xz
image, and installed gst-dsp with the steps described in the same wiki.

When I execute I get the following errors in dmesg:

[ 2080.014068] procwrap_detach: deprecated dspbridge ioctl

and from gstreamer:

0:00:01.488189698 5391 0xdb8580 ERROR dsp
gstdspvdec.c:180:create_node:<dspvdec0> dsp node create failed

I'm using the following command:

gst-launch filesrc location=videos/bourne.mp4 ! qtdemux ! dspvdec ! omapfbsink

I'm also attaching a GST_DEBUG=5 log output and my complete dmesg.

It seems I'm using a old dspbridge? If so, where can I find a newer one?

Any help would be appreciated,
Thanks,

dmesg (20 KB)

output.err (1.02 MB)

output (108 Bytes)

Please, upgrade to v3.2.1-x3..

wget http://rcn-ee.net/deb/oneiric-armel/v3.2.1-x3/install-me.sh
/bin/bash install-me.sh

in v3.2.x, dspbridge works better then in v3.1.x, with my kernel
images on the xM..

Although, for some reason it seems to lag at certain points while
playing video back..

Regards,

Hello,

I've installed Ubuntu oneiric in my beagleboard using the steps in
BeagleBoardUbuntu - eLinux.org, using
http://rcn-ee.net/deb/rootfs/oneiric/ubuntu-11.10-r3-minimal-armel.tar.xz
image, and installed gst-dsp with the steps described in the same wiki.

When I execute I get the following errors in dmesg:

[ 2080.014068] procwrap_detach: deprecated dspbridge ioctl

and from gstreamer:

0:00:01.488189698 5391 0xdb8580 ERROR dsp
gstdspvdec.c:180:create_node:<dspvdec0> dsp node create failed

I'm using the following command:

gst-launch filesrc location=videos/bourne.mp4 ! qtdemux ! dspvdec ! omapfbsink

I'm also attaching a GST_DEBUG=5 log output and my complete dmesg.

It seems I'm using a old dspbridge? If so, where can I find a newer one?

Any help would be appreciated,
Thanks,

Please, upgrade to v3.2.1-x3..

wget http://rcn-ee.net/deb/oneiric-armel/v3.2.1-x3/install-me.sh
/bin/bash install-me.sh

in v3.2.x, dspbridge works better then in v3.1.x, with my kernel
images on the xM..

Although, for some reason it seems to lag at certain points while
playing video back..

Thanks! Will do! Didn't expect an answer so quick!

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

Regards,

Unfortunately I get the exact same error as before.

Yeah, actually ran into the same problem last week, that kernel build
had my fixes to get things working again. :slight_smile:

Regards,

[snip]

Yeah, actually ran into the same problem last week, that kernel build
had my fixes to get things working again. :slight_smile:

I'm seeing this from dmesg.

[ 20.422668] bridgedriver: module is from the staging directory, the
quality is unknown, you have been warned.

This is expected?

Regards,

--
Robert Nelson
http://www.rcn-ee.com/

Thanks,

Yeap, any kernel driver under /drivers/staging/ gets that warning when loaded..

Regards,