Ubuntu: Setting Pin Mux?


I failed under Ubuntu 12.04 setting mux pins. It seems that I have even with sudo no permission for the debug directory.
No problems to perform it under Angstroem.

Last login: Mon Jun 25 08:56:45 CDT 2012 on ttyO0
Welcome to Ubuntu 12.04 LTS (GNU/Linux 3.2.0-psp7 armv7l)

  • Documentation: https://help.ubuntu.com/
    ubuntu@omap:~$ echo 7 > /sys/kernel/debug/omap_mux/gpmc_ad2
    -bash: /sys/kernel/debug/omap_mux/gpmc_ad2: Permission denied

ubuntu@omap:~$ sudo echo 7 > /sys/kernel/debug/omap_mux/gpmc_ad2
-bash: /sys/kernel/debug/omap_mux/gpmc_ad2: Permission denied

Thanks for a hint for a linux newcomer.

Many thanks and best regards

2 options.. switch to root via "sudo su" or use tee...

echo 7 | sudo tee /sys/kernel/debug/omap_mux/gpmc_ad2


Hi Robert,

Many thanks for your quick response.
Works perfectly now.

Best regards