(ubuntu xorg) keyboard and mouse did not working.

I tried to install ubuntu on my BB following the instruction this web

sudo aptitude install xorg gdm xfce4 (375Mb)

Modify /etc/X11/xorg.conf

Section "Device"
        Identifier "Configured Video Device"
        Option "UseFBDev" "true"
        Driver "fbdev"

I did that section.
and I did type startx instruction on my shell.
first time my BB works
before the login window my keyboard and mouse are good.
in login window only 2~3 second my keyboard and mouse are working.
but 3 second later, my keyboard and mouse did not working. (stop mouse
and key cursor stop)
I changed hub and keyboard. but It did not working too.

In short, my BB always stop in login window. but keyboard and mouse
did not working.

How can I solve this problem?

help me, plz.


Note: Since this is an email list, you really don't have to start a
new message thread..

Okay back to the problem, what else did you install on your
beagleboard after the usb hardware had worked the first time before
the reboot? It shouldn't just stop working unless the hub either
locked up, or something installed took control of it. (thinking like
some xorg input devices..)

What USB hub are you using? From you log you posted in the previous
message, it looks like the beagleboard did not see it at all. Does it
work with a newer kernel such as :


Here's a remote possibility. Are you using a self-powered hub, i.e.,
one with an external power supply? The BeagleBoard OTG port can only
source 100mA of power to USB devices, which is generally enough for a
keyboard or a mouse, but usually not a hub, a keyboard, and a mouse.
If your hub is getting power from the BeagleBoard it won't reliably
power all three devices and could result in behavior like what you're