udev rule for user access to usb device does not work

I wrote a udev rule:

rose@beaglebone1:/home/rose(42)$ ll /etc/udev/rules.d/52-usblib.rules
-rw-r–r-- 1 root root 122 Oct 12 20:42 /etc/udev/rules.d/52-usblib.rules
rose@beaglebone1:/home/rose(43)$ cat /etc/udev/rules.d/52-usblib.rules
SUBSYSTEM=“usb”, ENV{DEVTYPE}==“usb_device”, ATTR{idVendor}==“0547”, ATTR{idProduct}==“a00a”, MODE=“0664”, GROUP=“users”

The same rule worked on other linux systems like a charm. At the beaglebone a test programm started by an ordinary user hangs with a USB error:

rose@beaglebone1:/home/rose/Txt/projects/(40)$ ./chk_cam.sh
libusb: 0.000000 error [op_kernel_driver_active] get driver failed error -1 errno 9
libusb: 0.001356 error [op_claim_interface] claim interface failed, error -1 errno 9
^C

If I start the programm as root, it works without problems:
root@beaglebone1:/mnt/home_leopard/rose/Txt/projects/(2)# ./chk_cam.sh
[InitDevice] return 0.
[DeviceCount] find 1 devices!

You’re sure you’ve added ‘rose’ to the users group?

Thanks Nick, you are right, user rose was not member of users group, I thought, that every ordinary user is member of the users group.
I now tried to add user rose to the users group with ‘usermod -a -G users rose’. Now I find a rose entry in /etc/group, but nevertheless ‘id’ does not show that user rose belongs to users group. And if I start my programm as user rose it fails as before:

rose@beaglebone1:/mnt/home_leopard/rose/Txt/projects(29)$ grep rose /etc/group
users:x:100:rose
rose:x:1003:

rose@beaglebone1:/mnt/home_leopard/rose/Txt/projects/(30)$ id
uid=1203(rose) gid=1003(rose) groups=1003(rose)

What I am missing?