uImage Issues

So it seems that the 2.6.27 image from

Has the serial ports working and I can talk to the serial stuff
great:) Unfortunately the Ethernet is not recognized in this one so I
cannot download a c or c++ compiler:(

So it seems that the 2.6.28 image from
Has Ethernet working:) but the serial ports dont work:(

So the Question is Can Somebody please post an image with both of
these things working. And even better an image with both working and a
desktop image that works. The only one from


that has a desktop is 2.6.26. but the ethernet does not work on that

So can someone that knows how to compile images put one together with
all of the stuff working? that would be awesome???

Thanks for all of the help!!!

Have you tried building an image online?

Haven't tried it myself yet but I guess that would be a possible
solution for you.


I tried to build the image but the images that get build, even with
the small image builder will not fit on the sd card that I have after
I formatted it like http://code.google.com/p/beagleboard/wiki/HowToGetAngstromRunning
recommends. So I think I need to figure out how to format the 2gig sd
card I have so that it will accommodate those images. I am not very
handy with OE or formatting the sd card so that is causing a lot of
problems. Anyways thanks for the suggestion.

If you followed that, then I guess you saw
http://code.google.com/p/beagleboard/wiki/LinuxBootDiskFormat . That
page is general for every size of card, it'll just give you a 50MB
fat32 partition at the start and then use the rest for ext3, so
everything should fit nicely on that 2GB card you've got.

The problems you are having have to do with the way your kernel is built and
your system configuration.

When your kernel is loading, make sure you see a line showing that the
MOSCHIP USB to Ethernet driver is loaded, If you don't see this, then the
kernel was built without the USB MOSCHIP driver installed. If you don't see
this line, let me know and I will show you how to build the kernel with this
driver enabled.

Here are some configuration issues you need to fix.

To get a login prompt on the serial port, do the following:
1) With your SDCard installed in your host PC, you will need to have
root permissions to do the following changes. Please make sure ou are
changing these files on the SDCard, and not on your Host PC. In Ubuntu Linux
8.10, the easiest way to do this is to start a root file browser by issuing
the following command "gksu nautilus" (no quotes required). Enter your
password and now all files you edit will be done as root.
2) Browse to the second partition on your SDCard.
3) Add ttyS2 to the file /etc/securetty
4) In the folder /etc/event.d, copy tty2 to ttyS2.
5) Edit the file ttyS2. Add "start on runlevel 4" and "start on
runlevel 5". Remove "stop on runlevel 4" and "stop on runlevel 5"
6) Replace all tty2 with ttyS2.
7) Replace 38400 with 115200.
8) Save the file ttyS2.

To get your Ethernet working, do the following:
1) Edit /etc/network/interfaces
2) Add the following - I don't know what your IP address of your
network is, so assuming your network is 10.100.10.x
auto eth0
allow-hotplug eth0
iface eth0 inet static
3) If you want to use DHCP, use the following
auto eth0
allow-hotplug eth0
iface eth0 inet dhcp
4) Save file interfaces
5) In file /etc/resolv.conf, add the ip address of your DNS server

To get sudo to work, do the following:
1) Change the root permission of /etc/sudoers to rw
2) Edit the file /etc/sudoers
3) Remove the # before the %sudo
4) Save the file /etc/sudoers
5) Change the root permissions of /etc/sudoers to r
6) Add your userID to the sudo group in the /etc/group file.

I hope this helps.