ulcd7 lite touch not working-pls help

hi all

i have been trying to interface ulcd7 lite to beagleboard-xm. even though i am able to get display the touch is not working…

i have linux-omap-3 kernel and i have neatly applied the keons patch found in

stil i m not able to get touch working…
there are no devices found under /dev/input/touchscreen0

kindly help

hi andy

thanks for reply

do u mean, the problem may be due to the different board id ?
which piece of code i need to look in to solve the touch issue … ?

hi all

now i am able to get /dev/input/touchscreen0 device

when i run the ts_calibrate and ts_test i m getting error like below

root@beagleboard# ts_calibrate
xres = 800, yres = 520
selected device is not a touchscreen I understand
Took 2 samples…
Top left : X = -546334668 Y = -546334549
Took 2 samples…
Top right : X = -546334668 Y = -546334549
Took 2 samples…
Bot right : X = -546334668 Y = -546334549
Took 2 samples…
Bot left : X = -546334668 Y = -546334549
Took 2 samples…
Center : X = -546334668 Y = -546334549
-1.468750 -3.414062 3.421875
-1.828125 -2.226562 2.228516
Calibration constants: -96256 -223744 224256 -119808 -145920 146048 65536

root@beagleboard:# ts_test
selected device is not a touchscreen I understand

touch is still not working… kindly help us to resolve the issue

Hi Kiran,
It’s looking like I have an eeprom problem. My old working touchscreen has 0x0 0x0b 0x00 0x04 as the first registers in the ulcd7 board eeprom. The rest is 0xff. On the new non-working touchscreen the eeprom contains all 0xff. I think they didn’t program the eeprom and so the beagle does not recognize the tsc2007 chip responsible for reporting touch info. I guess my next step is to pull some resistors and reprogram the eeprom to see if that works.

I’m not sure if this relates to your problems but you could easily check by getting the i2c-tools package and running i2cdump on the eeprom.

hi Andy

i will consider your suggestions… but the Datasheet of ulcd7 lite also says that it uses tlc59108 LED driver for some LCD initialization using I2C
anyways i will give a try
thank u

I reprogrammed the EEPROM and it still didn’t work. But for my configuration (3.2.30, ubuntu, xorg, openbox) I had to remove a mysterious utouch package. I got rid of anything with utouch in it and now it works. But I upgraded my kernel to 3.6 and now it doesn’t work again…

hi Andy

i checked the eeprom contents and found that they are proper as given in the link of beagleboard toys
that is 00 0b 00 04…

when i test the board under angstorm linux(3.2 ) i m getting touch events on /dev/input/event0 whenever i tap the board
but my issue is that tslib applications like “ts_calibrate” and “ts_test” are throwing the error like
"selected device is not a touchscreen i understand " and i could not test any touch application properly

ok finally the touch screen calibration apps are working(get rid of "selected device is not a touchscreen i understand " and "segmentation fault " errors when i removed the tslib components of angstrom repo and
build it my own by referring this tutorial… it may help others

thanks Andy for your suggestions