Unable to compile gst-openmax

I had this same error.

error: AC_INIT should be called with package and version arguments

You said that you made a .version file. I'm not exactly sure what
that is or how to make it to fix this problem.
I assume its a file with a version number in it, but beyond that could
you give more details please?

After running Autogen.sh I got the following:

+ configure run disabled
+ check for build tools
  checking for autoconf >= 2.52 ... found 2.65, ok.
  checking for automake >= 1.7 ... found 1.11.1, ok.
  checking for libtoolize >= 1.5.0 ... found 2.2.6b, ok.
  checking for pkg-config >= 0.8.0 ... found 0.22, ok.
+ running aclocal -I m4 ...
fatal: No names found, cannot describe anything.
configure.ac:7: error: AC_INIT should be called with package and version arguments
/usr/share/aclocal-1.11/init.m4:26: AM_INIT_AUTOMAKE is expanded from...
configure.ac:7: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1

aclocal failed