Unable to compile gst-openmax

Hi,

I'm trying to compile gst-openmax inside scratchbox2 following
Felipe's instructions at http://elinux.org/BeagleBoard/gst-openmax,
but the autogen.sh script fails with the following error:

OK. I managed to compile the source just adding a .version file in the
main directory. I think the error was due to the attempt to get a
version from git.

However, when I try to execute the pipeline as per Felipe's
instructions I got the following error:

OK. I fixed this issue (and another one raised, but I will open
another thread...).

The problem is in libomxil-ti compile command. The BRIDGE_LIBS
variable passed to the make command should also include a "-lbridge"
option otherwise the library will not be linked. Moreover, the "-L"
path is wrong because libbridge.so is placed in the top-level
directory of the library source tree. Therefore the right command is:

make BRIDGE_CFLAGS=-I../libdspbridge/inc BRIDGE_LIBS=-L../libdspbridge
-lbridge DESTDIR=rootfs install

Cheers

Pietro

Ooops! Forgot to put quotes in BRIDGE_LIBS. The right command is:

$ make BRIDGE_CFLAGS=-I../libdspbridge/inc BRIDGE_LIBS="-L../
libdspbridge -lbridge" DESTDIR=rootfs install

Pietro