Unable to connect to

I followed the instructions on the Start page but, Chrome gives “Oops! could not connect to”

None of the previous posts about Cloud9, etc… makes sense.

Did you look under the FAQs on the support Wiki?




This one specifically will help

I am having similar problems. I have tried the remedies posted elsewhere in this group forum regarding deletion of the ‘dropbear_rsa_host_key’ and restarting dropbear - they didn’t work for me. I have posted a help request at Adafruit Support where I bought my BBB last week. If I learn anything new I will share with the group. Thanks.

Haven’t got a clue about this bear junk. I traced the REAL PROBLEM to the 64 bit drivers. The connection works with the 32 bit driver on my 12 year old laptop but, the connection failure come with the 64 bit driver.

Like I stated, I could not get a connection to much less try to run ssh.

I downloaded the newer image and try to boot from the uSD and my machine indicated that the “mass storage drive” needed to be scanned for errors.

I am forced to drop Angstrom and move toward Ubuntu or Android.

In my case, I was forced to give up on the Angstrom image as shipped.

I am now running a newer Angstrom image (2013.06.20 unflashed) off of a 4GB microSD card. After booting with that image I had to clear some new problems by using opkg update/upgrade.

Windows Hyperterminal served me well when I was not able to SSH into the BBB or launch Cloud9 IDE. It was my only option to run opkg. The Ethernet pings OK in Hyperterminal and Gate One now.

It is still necessary for me to be tethered to my Windows XP SP3 machine with a serial cable. In the short run this is OK as I will be able to learn Linux and Bonescript/Node.js, but in the long run I will need to learn how to use the BBB when it is in a different room, building, or county.

I hope that I can get the same results. I’ll have to delete the image I downloaded a couple of days ago and try to get my BeagleBone Black to boot off the uSD. Before I do this can anyone inform me what is the MD check box used for on the Image Writer GUI???

Michael, can you post instructions or point me to a web site that allows me to use a terminal program?


You can check this wiki out for a terminal program. http://circuitco.com/support/index.php?title=Terminal_Shells

Is it possible to update to a new “image” just by updating everything with opkg?

Unfortunately not. You need to update it as described in this wiki. http://circuitco.com/support/index.php?title=Updating_The_Software

There is also speak of an update method over USB cable in the future. But that may not be for some time now.

I’m curious “why not”?
What pieces can’t be updated with opkg?

I’m not sure exactly so don’t quote me.
If you do:

opkg update
opkg upgrade

I believe it applies updates to some of the packages that come pre-installed on Angstrom.
If you really want to know you can just invoke those commands and read the terminal as it tells you what its updating.

@ Bill lewis, technically, yes you can. However there is / was glitch where you were forced to overwrite some files. I did a netupdate using these steps from 3.8.6 to 3.8.8 where the Angstrom image still sits.As far as I can tell it works perfectly, but I run Debian now ( since then ) off of other media ( uSD, netboot, or USB boot)

  1. mkdir ~/mytmp
  2. opkg update
  3. opkg upgrade -t ~/mytmp
  4. opkg --force-overwrite install kernel-image-3.8.x

These are the exact steps I took to update my Angstrom install. No idea if this will still work, so if you follow these steps, you do so at your own risk. This might be worth checking though if you plan on updating via uSD card anyhow.

Oh and to make things crystal clear, 3.8.x should be whatever kernel image you plan on using. so 3.8.13-20bone, or whatever the newest image is

My problems have returned. I disconnected from my Windows XP this morning and have been trying for 2 hours to reconnect in a manner sufficient to run Cloud9 IDE and Gate One SSH. I keep getting an error icon in the Windows XP system tray - ‘Local Area Connection 4 A network cable is uplugged’. (Nothing is unplugged because Hyperterminal works - see below.) I think this error message means there is a problem on the BBB end of the cable, not Windows. Does anyone have any suggestions regarding this error?

To answer your terminal program question - I am using Windows XP SP3, which has a utility called ‘Hyperterminal’, a very old* EXE program that does not run in your browser. So, it seems to bypass the Linux RNDIS connection which seems to be failing on my machine, i.e. - it is working now despite the aforementioned error.

I am able to get Hyperterminal to work with a connection definition as follows:

bits per second: 115200
data bits 8: 8
parity: N
stop bit: 1

I got this information from the Adafruit Learning site a few days ago - it’s a routine for setting up the predecessor Beaglebone White. Try this link:


Using Hyperterminal, I found the following file with today’s date (8/1/2013) and ran a CAT on it:

At risk of offtopic? Would these commands be relevant if the same situation was on linux?

sudo ping -I enp0s29u1u4u2
sudo ifconfig enp0s29u1u4u2

I can’t see any mention of these in the tutorial for cnonecting via usb… but I don’t see the local interface on the laptop getting an IP via any DHCP server on the beagle

My experience is on Windows (7, Vista and XP). I do not know if the connection problem is on Linux. The “instructions for the connection” is in the get started page of the BeagleBone Black. A successful connection gets their Bone101 page which was transmitted vie USB to Chrome (my case). No Ether cable required.

This problem is a network adapter problem.

Did you check here?