"Unable to create file links" error when installing sourcery

Hello all,
basically, I have exactly the same problem as this guy:
http://groups.google.com/group/beagleboard/browse_thread/thread/a4b33fdd5d986f44

"I have incurred a problem installing CodeSourcery (cross compiler
tool). The
download was successful from google code web page.
Everything seems to be fine till the last moment of installation when
an
error occurs saying "Unable to create file links.....An error occurred
while
running internal programs"."

I am doing the installation on an EXT3 partition, with the 2007
release. Any ideas on how to correct this problem?

And btw, the "installer" seems to hijack my keyboard when the error
pops up; I can't type anything, in any program. Nice.

Jyaif:

This is just a guess as I have never installed CodeSourcery in a Linux
system.

It sounds to me like a problem with directory permissions. You might
need to log in as root to do the installation. It would be nice if
CodeSourcery indicated which file links it could not create, but you
get what you pay for.

You also might try downloading directly from CodeSourcery at:
http://www.codesourcery.com/sgpp/lite/arm/portal/release313.
This is "Sourcery G++ Lite 2007q3-51 for ARM GNU/Linux", which is the
release most recommended for BeagleBoard.

Hope this helps,

John

I was having this problem installing the

I was having the same problem installing on Ubuntu 9.04 using the
installer arm-2007q3-51-arm-none-linux-gnueabi.bin. Since I had the
right permissions, and I was installing on an ext3 file system, I
tried changing the ownership of the installer to root instead of
user. That seems to have worked -- I only got one warning that the
installer was unable to modify PATH to add the tools.

Hope this helps.

Jim