Unable to enable BB-UART1 at boot time

I am trying to enable BB-UART1 at boot time in BeagleBone Black but it’s just not happening. Once the BBB is booted I can manually write “echo BB-UART1 > /sys/devices/bone_capemgr.*/slots” in shell which enables the ttyO1. When I put this inside /etc/rc.local ttyO1 is not enabled at boot time contrary to what I expect. Also putting it in crontab with @reboot doesn’t seem to work either. Please help.


# #append this to the end of the single line of uEnv.txt (not on a new line):
# capemgr.enable_partno=BB-UART1