Unable to Flash the internal eMMC of BBB Rev C

Board: Beagle Bone Black RevC

i have downloaded the latest linux debain image and written the image to SD card via win32 image writer

now my problem is

when i press the boot button during powerup the booting happens from SD and further all leds lit at a time then they all go off and leds keep on glowing not following any pattern and i am able to login via ssh

i searched many guides in which they explain the same above process even to flash the on board eMMC, i was not able to see the current flashing status of write over eMMC (some said i can see it over UART(J2) but i dont have one now :frowning: )

how to differentiate whether i am booted through SD / currently flashing the eMMC (are both independent ? / or the OS done in background ?)

is there any special led pattern i can observe during the process of eMMC flashing ?

i tried some different stuff also, like after logging in via SSH i just brought the image.xz in to my /tmp folder of board and did the below

....

and the name of the "file" you flashed to the eMMC was?

"unless" it specifically was called "eMMC-flasher" it's only going to
run standalone on the microSD. To change it to "flash" the eMMC read:

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Flashing_eMMC

We had "5" different images released for "2015-03-01" each one is
identified by it's file name

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#2015-03-01

Regards,

bone-debian-7.8-lxde-4gb-armhf-2015-03-01-4gb.img.xz was the image which i have put to SD

Then the image was working perfectly as it was required.

Issue closed, read the FAQ to convert to flasher... :wink:

Regards,

Flasher: (lxde)

Flasher: (console)

what is the difference between the both , by the way i have started to download the first

Please don’t close the issue, i did not understand your reply :slight_smile: , please answer my questions

Hello Shyyam,
I don’t know exact way how to convert to flasher from standalone. But method I followed was download eMMC-flasher image from here. And follow the same steps you did for normal standalone image md5sum, unxz and write it to microSD. It will solve your problem.
Regards,
Upol

Well one is the full "lxde" desktop and the other is a minimal "console"..

Regards,

It's closed... The reason it wasn't auto flashing is you didn't dd the
"eMMC-flasher" image. Thus there isn't anything to "fix"..

I had also sent you a link to "convert" your already flashed
"no-flasher" to a "flasher"..

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Flashing_eMMC

Regards,

Im Done thanks very much

I’m having the same “problem” with BBB rev C & BBG WiFi and I also came to conclusion that something was not explained right, or that SW flashing package was not “packed” well for novice users.

And I just need to say that answer as such is very immature, specially giving the amount of interest that is being generated towards the growing audience.

So, I’ll ask again:
How do find uEnv.txt? Is it on the uSD or should I terminal to the BBB?
If this is on the uSD, how do I access it on OS X or W based OS?

And the last thing, I’m newbie too. So don’t be mad at me for asking your help.

On Wed, 14 Sep 2016 01:56:38 -0700 (PDT),
zeljko.m85@gmail.com declaimed the following:

So, I'll ask again:
How do find uEnv.txt? Is it on the uSD or should I terminal to the BBB?
If this is on the uSD, how do I access it on OS X or W based OS?

  In order:

Exactly where
http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#Flashing_eMMC states:
/boot/uEnv.txt.

Yes and yes.

Maybe OS-X but not Windows.

  The current images (in my experience) no longer include a separate
FAT-type partition for the initial boot, so Windows doesn't see anything on
the card that it can mount; OS-X might understand the partition format
(ext3?) so could navigate to the location.

  Easiest route... Boot with the SD card in place, use a terminal to
navigate and edit, then reboot and watch it flash... Then remove the SD
card and reboot using eMMC with new image.

  I usually then reburn the SD card with the non-edited image to make a
stand-alone booter -- which I expand to the full 8GB of my cards. I need to
experiment, but I think the last time I tried, booting off eMMC and /then/
inserting the SD card gave me a mounted partition that I could have used to
reverse the edits -- instead of reburning the SD card. Think I've also seen
that booting with the SD card mounts the eMMC also, so I could copy
home-directory config files from one to the other. When I tried last year,
the SD card wasn't auto-mounted, and I'm not "Linux" enough to figure out
how to access it.