Unable to locate package linux-headers-4.4.91-ti-r133

I’m trying to foolow Derek Molloy’s tutorial “Writing a Linux Kernel Module” http://derekmolloy.ie/writing-a-linux-kernel-module-part-1-introduction/
According to the blog it is needed to install the linux-header files.
I’m using debian 4.4.91-ti-r133.
On the command: sudo apt-get install linux-headers-4.4.91-ti-r133
I get the error message:
Unable to locate package linux-headers-4.4.91-ti-r133
The command: apt-cache search linux-headers
shows only headers with the version: linux-headers-4.9.0-4
Can anybody please give some advice how to proceed?
Thanks in advance

Refresh your apt cache:

sudo apt update

then you can run:

sudo apt install linux-headers-`uname -r`


Thanks for your answer, but it didn’t help.
I tried:
sudo apt update
sudo apt-get update
sudo apt-get upgrade

but still
The command: apt-cache search linux-headers
shows only headers with the version: linux-headers-4.9.0-4
sudo apt install linux-headers-$(uname -r)
results in
Unable to locate package linux-headers-4.4.91-ti-r133

So… I got it!
downloaded the headers from
installed the headers with
sudo dpkg -i linux-headers-4.4.91-ti-r133_1stretch_armhf.deb

sudo apt-get update did not work because the URLs
#deb [arch=armhf] http://repos.rcn-ee.com/debian/ stretch main
#deb-src [arch=armhf] http://repos.rcn-ee.com/debian/ stretch main
were outcommented in my /etc/apt/sources.list
I’m not sure if it was outcommented from the download or if I did it myself accidently

The first one is enabled by default on the uploaded images.

Otherwise, debootstrap can't pull in the kernel.. :wink:


Yes, it was my mistake.
Thanks for the help.

sir i have same problem i did it what have u suggested but i cant get of my version.plz help my whatsapp number is +918563078782

hi i have same problem please mail me or whatsApp me as soon as possible please help me my number is +918563078782.please please please please

my version is vi3.8.13-bone50
hi please help me i have same problem my whatsapp number is +918563078782.


Jeepers! There's asking for help… and then there's practically
screaming the place down as if you're being murdered!

A few points:
1. We're not all running the same timezone and schedule as you.
2. We're volunteers… we're going to respond on *our* schedule, not
yours, *IF* we are able to help. This is *especially* true at this time
of year, where many of us will be busy *away* from computers (spending
time with friends and family for example).
3. Repeatedly asking "help me" and providing no further information on
what you've done to solve the problem does not inspire any of us to
assist, as it shows a lack of initiative in researching the problem.

Replying to a thread can be okay if you reply with additional
information you have found or with different experiments you have
attempted… this shows you're at least trying to work the problem, and
may help someone else that winds up in your situation in the future.

Now… with that underway…

It sounds a lot like APT is picking up on the standard `linux-headers`
package that Debian ship; and kernel version 3.18 is rather dated now.
So likely you're running an out-dated image.

That's a guess on my part though, as I am new to the Beagle Bone
ecosystem myself. (I have a few years experience with Linux on RISC,
and about 20 with Linux itself, but bought my first BeagleBone a few
weeks back.)

1. What BeagleBone image are you running?
2. Have you tried doing an `apt-get update; apt-get dist-upgrade` to get
everything up to date?
3. What does `apt-cache policy linux-headers` display?

Ignore works well

hi man,
i m very new with beaglebone black,
my version is BBB-eMMC-flasher-debian-7.5-2014-05-14-2gb.
when i did ‘uname -r’ i got vi3.8.13-bone50 .
i have tried sudo apt-get update and all the things.
and i m hoping u ll help me from starting.
and also ll send me the link of latest version too.


there is all image suggest me which one should i download and port it.

Well, I personally started with the ones listed here:

which is the link mentioned in the QuickStart documentation. The first
link needs a 4GB or greater MicroSD card (did try cramming it onto a 2GB
card, things did not go well).

Graham (in
also pointed to the following site:


… of which the most up-to-date would be the Debian Stretch versions:


I haven't tried any of those images however… I do have the "console" one
downloaded for later, but for now I'm using the "IOT" version that I
originally downloaded from the "latest images" link above.

I recommend that you get this book as it will cover all the things you need:

Mastering Embedded Linux Programming - Second Edition by Chris Simmonds
Published by Packt Publishing
Released June 2017

Covers Linux Kernel 4.9 and uses the BBB hardware.


I am trying to understand why it isn’t possible to have the package available out of the box so users can simply do the following.

$ sudo apt-get install linux-headers-$(uname -r)

It seems this would be common with a Debian distribution.

What do you mean?

In this "thread" the user "commented" out the "repo", so they "couldn't" use:

sudo apt install linux-headers-`uname -r`

Out of the box, it's setup so you can do that, they just disabled it...


I apologize I did not catch that.