unable to login to root after I updated my beagle board black to debian 9 images


I am new to using a beagle board and I just updated it to the debian 9 images. Before I updated it, I was successfully logging in to root without a password through Putty. I never created a password for root. After I updated and flashed it to the board, i was asked for a password for root whenever I logged in and I do not know what password to put in. I have tried ‘temppwd’ and that did not work. I tried logging in to debian and that has worked successfully.

it looked like this in Putty after the update:

login: root
root@’s password:
Password denied

Can I just use debian or am I supposed to login to root every time? I have a project involving this beagle board and I was wondering if logging in as debian is fine.

It’s considered poor form to log in to root directly these days, particularly over ssh. Instead you log into a user account and either sudo or su to do what you require. It is wise to change the root password, so just log in as debian, sudo -s and then set the root password. If you choose to log in as root thereafter, you can do so, but you should check to see that root logins are allowed in sshd.conf.

In direct answer: logging in as debian should be fine, but it’s not root. (Generally that’s a good thing)



Thank you!