Unable to ping host machine


I’m using MATLAB to program my beagleboard xm. I ran into a strange problem. I’m able to ping the board from my host machine (Windows 7) but not the other way around i.e. I cannot ping my host from the bbxm. Here are my results for ifconfig on the bbxm:

ubuntu@bbxm:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 3e:7f:da:ee:b1:db
inet addr: Bcast: Mask:
inet6 addr: fe80::3c7f:daff:feee:b1db/64 Scope:Link
RX packets:297 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20184 (20.1 KB) TX bytes:4860 (4.8 KB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:22 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1656 (1.6 KB) TX bytes:1656 (1.6 KB)

My BB OS is ubuntu

ubuntu@bbxm:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Any idea what’s causing this? Thanks!

What is the contents of /etc/resolv.conf ?

Hi William,

ubuntu@bbxm:~$ cat /etc/resolv.conf
domain mathworks.com
search mathworks.com


Ok, I am not sure what you’re doing there, but those nameservers do not match your ifconfig output.

Try commenting out all of those atleast temporarily by adding a pound sign in front of ech statement ( # ) andthen add . . .


Just for kicks what do you have in /etc/network/interfaces ?

I get this:

ubuntu@bbxm:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
hwaddress ether 3e:7f:da:ee:b1:db

That gateway address should be wrong. That would be the network. may be the gateway / nameserver, but i am not sure how your network is setup.

How are your BBxM and host computer connected ? USBNET or ethernet ? IS there a router between the two systems or is teh BBxM connected directly to the host computer ? Host to me implies they are directly connected, but I do not remember if the xM has onboard ethernet or not.

Please refer to “How to enable ICMP echo requests (Ping) in Windows XP” (http://wiki.phys.ethz.ch/readme/how_to_enable_icmp_echo_requests_ping_in_windows_xp_service_pack_2).

Hi William, is the ip of my modem…should it also be used as my default gateway?

My bbxm and host are connected via ethernet…directly. The bbxm does have on-board etherne

Hi Tsan-Ming Chou…that worked! Thanks a lot! And thanks for your time too, William Hermans!

You are welcome.

well first, I am not a network guru, however I think that. . .

nameserver in /etc/resolv.conf would be ( assuming by modem, its a DSL/cable modem + router)

gateway in /etc/network/interfaces would be your host computers ip

Then, you BBxM would be any IP in the same range as your host computer. would work fine as long as there was nothing else on the network with this IP already.

Anyhow, sounds like you’ve solved your issue already, but you did have some funky settings anyhow. SO they already needed fixing.