Unable to read "boot.scr"

Hi,

trying to boot linux on beable board with angstrom demo. I see following errors. says unable to read boot.scr , cannot get kerner image etc

any solution for the problem??

Hit any key to stop autoboot: 0
mmc1 is available
reading boot.scr
** Unable to read “boot.scr” from mmc 0:1 **
reading uImage
** Unable to read “uImage” from mmc 0:1 **
Booting from nand …
NAND read: device 0 offset 0x280000, size 0x400000
4194304 bytes read: OK
Wrong Image Format for bootm command
ERROR: can’t get kernel image!
OMAP3 beagleboard.org #

-aamer

Dear Aamer:

I suspect U-Boot is trying to load uImage.bin and your image is named uImage (or vice versa).

Charles

Hi Charles,

Thank you for the reply.

I have tried it, but i see the same problem. let me put in detail
what i have done until now. verified initial BB boot without using SD
card. then partitioned SD card as per instructions (on linux PC) at
http://code.google.com/p/beagleboard/wiki/LinuxBootDiskFormat

added latest files from http://www.angstrom-distribution.org/demo/beagleboard/
to fat32 part and ext3 part.

powered up BB, then hit key to stop auto boot , setenv for bootargs,
boot cmd and saved it using saveenv.

later restarted the board while pressing user button. now i see
following errors on hyperterminal (windows PC)

Unknown command 'mmcinit' - try 'help'

** Unable to use mmc 0:1 for fatload **
Wrong Image Format for bootm command
ERROR: can't get kernel image!
OMAP3 beagleboard.org #

seems some prob with 'mmcinit' command what i have used during setting
bootargs and boot cmd.

any kind of suggestion will be appreciated.

-aamer

Fri, 25 Sep 2009, raqeeb wrote:

Unknown command 'mmcinit' - try 'help'

seems some prob with 'mmcinit' command what i have used during setting
bootargs and boot cmd.

There is no such command anymore as 'mmcinit'. It's 'mmc init' nowadays.

Dear Antti,

that works!! still could not see messages of kernel booting, but the following:

Hit any key to stop autoboot: 0
mmc1 is available
usage: fatload <dev[:part]> [bytes]
OMAP3 beagleboard.org #

does the below messages show any problem with fatload ? i did it as given below

setenv bootcmd ‘mmc init; fatload mmc 0 80300000 uImage.bin; bootm 80300000’

Thanks in advance for your help.

-aamer

Hi

Hit any key to stop autoboot: 0
mmc1 is available

usage: fatload <dev[:part]> [bytes]
OMAP3 beagleboard.org #

does the below messages show any problem with fatload ? i did it as given below

setenv bootcmd ‘mmc init; fatload mmc 0 80300000 uImage.bin; bootm 80300000’

Try setenv bootcmd ‘mmc init; fatload mmc 0 0x80300000 uImage.bin; bootm 0x80300000’

HTH
Kedar

Hi Kedar,

it doesnt work. i get the same fatload message…

this is what i have tried

OMAP3 beagleboard.org # setenv bootargs 'console=ttyS0, 115200n8

root=/dev/mmcblk0p2 rw rootwait’
OMAP3 beagleboard.org # setenv bootcmd ‘mmc init; fatload mmc 0 0x80300000
uImage.bin; bootm 0x80300000’
OMAP3 beagleboard.org # boot

for info, i have used Angstrom-Beagleboard-demo-image-glibc-ipk-2009.X-unstable-20090903-beagleboard.rootfs.tar.bz2 for partition 2 and uImage-2.6.29-r44-beagleboard.bin for partition 1 and renamed it to uImage.bin as the U-boot prompt was looking for uImage.bin name

Any suggestions?

-aamer

Hi,

finally this worked!!

setenv bootargs ‘console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait omapfb.video_mode=1024x768MR-16@60’