Unable to receive data via serial line


I had recently bought a Beaglebone Black rev C and was getting started following online tutorials
I tried to setup basic serial communication with BBB through J1 serial connector

I am able to transmit data from my laptop to BBB via serial line and I can see the data coming to /dev/ttyO0 successfully
But receiving data from BBB is not working
Only once receive worked where it showing just gibberish in terminal and after that it consistently failed to work

dmesg or syslog doesnt show any errors
I checked for basic continuity and my USB to serial converter doesnt seem to one causing issue

Can anyone help me on this issue
Thanks in advance


If you suspect your USB serial converter, a quick test is to short the RX and TX and check that whey you type in your minicom/hyperterm you see the hardware echo it back (just make sure you don’t set it up for local software echoing).

Thanks for your reply
I tried that and its working fine
In fact, when BBB is not powered, I am able to see that the serial line between my laptop and BBB is working perfectly as a loopback
When I power ON the board, loopback disconnects and then nothing is received on laptop (or nothing is transmitted from BBB)

Should I enable UART0 on BBB, I was thinking that ttyO0 is enabled by default and that I am able to transmit data to BBB
Currently my BBB has Debian 4.6 (linux 3.8.13-beagle70)