Unable to recover the broken BeagleBoard

My beagleboard C4 can boot from SD card, so yesterday I was trying to
flash MLO and u-boot into NAND with the following cmd, according to
http://elinux.org/BeagleBoardNAND

OMAP3 beagleboard.org # mmc init
OMAP3 beagleboard.org # fatload mmc 0 82000000 MLO
OMAP3 beagleboard.org # nandecc hw
OMAP3 beagleboard.org # nand erase 0 80000
OMAP3 beagleboard.org # nand write 80000000 0 80000

OMAP3 beagleboard.org # mmc init
OMAP3 beagleboard.org # fatload mmc 0:1 80000000 u-boot.bin
OMAP3 beagleboard.org # nandecc sw
OMAP3 beagleboard.org # nand erase 80000 160000
OMAP3 beagleboard.org #

But after that, the board can't boot from NAND or SD. When I hold USER
button, the terminal only showed
"40W" without any further script.

I think I break the NAND, and then follow the MMC recovery steps in
http://elinux.org/BeagleBoardRecovery, but it didn;t work too.

1. why can't I recovery and boot from SD card?
2. Is there any approach to recovery the board?

Thanks

Zhen

It sounds like the SD card is either not properly formatted with the suggested format tool and/or the files are not copied in the correct order.

Gerald

Thanks, but before flashing MLO and u-boot from SD to NAND, the
beagleboard can boot from this SD card successfully.
So I think SD card should be OK.

Zhen

Should I try to recover from USB or Serial?

Is there any updated tutorial for recovery from USB or Serial?

Thanks

Zhen

As the board boots form SD OK, I would use the SD card method. Make sure you format it correctly and copy the files in the correct order.

http://code.google.com/p/beagleboard/wiki/BeagleboardRevC3Validation

NOTE: Use the files located here http://www.angstrom-distribution.org/demo/beagleboard/

Gerald

Yes, I followed the instructions strictly to partition, format, copy
files again.

But can't solve the problem.

When power up the board while pressing USER button, only has "40W"
shown on the terminal.

No further scripts.

What tool did you use to format the card?

Gerald

use

$ sudo mkfs.msdos -F 32 /dev/sdc1 -n LABEL1

$ sudo mkfs.ext3 -L LABEL2 /dev/sdc2

according to http://code.google.com/p/beagleboard/wiki/LinuxBootDiskFormat

OK. I suggest you follow the instructions on the link I sent you and use the tool that makes the card bootable so that the internal ROM of the processor can read it. It must be FAT or FAT32. The ROM cannot read EXT3 partitions. If you do this, the card will be bootable. Otherwise, it will never ever boot.

Gerald

Thanks for your help.

However, the instructions link you sent just redirects to the
instructions I used, since beagleboard V4 should follow the link
http://www.angstrom-distribution.org/demo/beagleboard/

The problem a 'standard' fat32 partition isn't always going to cut it..

Pick a scipt:

Angstrom's
http://cgit.openembedded.org/cgit.cgi/openembedded/tree/contrib/angstrom/omap3-mkcard.sh

or mine:
http://elinux.org/BeagleBoardUbuntu#Upgrade_X-loader_and_U-boot

Regards,

Thanks Robert. That was what I was just typing as to FAT32 not working. The scripts are a good way to go to make the card and it should boot just fine. However, make sure you have the script file on the card in order to flash the NAND.

Gerald

Thanks all ! the problem is solved! my beagleboard is recovered!

I first successfully recovered my board from UART by using Nishanth's
tools on [1] and following his instructions on [2] and YouTube video
[3]. After that, I can boot from NAND.

Then, I reformatted my SD card with Robert and Gerald's suggestion on
[4], and then the beagleboard can also boot from SD card when I
pressed USER button and powered it up.

Thanks a lot!

Zhen

[1] http://beagleboard.googlegroups.com/web/beagle_recover.tar.bz2
[2]
http://groups.google.com/group/beagleboard/browse_thread/thread/d97b2152fe7185dd/932f618adf67d035?lnk=gst&q=recover_beagle.sh#932f618adf67d035
[3] http://www.youtube.com/watch?v=zTBv2r_cDJs&feature=player_embedded#!
[4] http://cgit.openembedded.org/cgit.cgi/openembedded/tree/contrib/angstrom/omap3-mkcard.sh

Currently I have a new problem, after loading x-loader and u-boot, the
board doesn't load uImage, whether booting from NAND or SD.
And there is no prompt for "Hit any key to stop autoboot: "

what's the problem? Following is the detailed terminal scripts.

1) NAND boot scripts:

Well it's actually looking for a boot.scr...

Regards,

In fact, I copied all files required by
http://code.google.com/p/beagleboard/wiki/BeagleboardRevC3Validation
to SD card, including boot.scr.

My problem is that after x-loader and u-boot, there is no display of
"Hit any key to stop autoboot: " and don't give me the count-down. So
beagleboard didn't read boot.scr or uImage.bin

Then something else in the nand enviroment variables is stopping it..

this will clear out the nand enviroment variables:

nand erase 260000 20000

Regards,

It works now after using nand erase cmd!

Thanks a lot!

Zhen

Now I am going to flash NAND on beagle board. I don;t want to make
mistake to break the board again. So could you tell me which
procedures I should use to flash x-loader, u-boot and uImage to NAND.

I find there are two links
[1] http://code.google.com/p/beagleboard/wiki/BeagleNANDFlashing
[2] http://www.angstrom-distribution.org/demo/beagleboard/

They seem different, which one works for beagleboard c4?

Thanks

Zhen

Always use [2] it's updated before [1]...

For a very quick and dirty. You just have to lift a finger to push the
user button.

(same binaries as [2] just built on my pc..)
http://elinux.org/BeagleBoardUbuntu#Upgrade_X-loader_and_U-boot

Regards,