Unable to SSH to Beagle Bone Black

That worked fine. Thank you!

Works great. This shld be on stackoverflow. Very difficult to follow on google groups.

Thanks! This script worked for me!

Thankyou ,that really solve my problem . woooo

在 2013年5月2日星期四UTC+8上午5时39分49秒,cmicali写道:

This worked perfectly from cloud9. Thanks! It has to be done from cloud9 though as far as I can tell since not all the example text boxes have ‘fs’ available (not sure why).

I was having this same problem and this solved it perfectly. Thank you Jimmy!


Me and my colleague spent a day or two trying to fix issues like this that kept creeping up on our beaglebone black boards. We would be unable to SSH to them or it would hang at:
debug1: identity file /Users/cmicali/.ssh/id_dsa-cert type -1

It wouldn’t always say connection closed. I tried every single idea I saw posted in this thread and others.

In the end it seemed Avahi daemon was causing issues. I found this through the following:
1.) I ran “top” which showed me that systemd and systemd-journal were running at 100% of the CPU combined.
2.) I used “journalctl -b” to see what journal output was being created for this boot. This showed error after error for Avahi at full CPU speed.
3.) I stopped avahi-daemon, which I haven’t yet seen the ramifications of using:
systemctl disable avahi-daemon.service
4.) I ran “df -h” which showed me that my storage was completely used up!
5.) I located the log in /var/log/journal/
6.) I deleted all the files in the aforementioned directory
7.) I did as this thread suggests for the 20th time and deleted the dropbear_rsa_host_key file
8.) I stopped dropbear using: “/etc/init.d/dropbear stop”
9.) I started dropbear using “/etc/init.d/dropbear start”
10.) It proceeded to generate a new key.
11.) At this point I tried connecting again from a client which was successful.

Perhaps I could have stopped at step 6 and just stopped and restarted dropbear but that’s what I did to make it work! Hope this saves someone else a day -.-

Was there a conflict in hostname, i.e., two BBB with the same name?

For me, I would rather to have fixed IP addresses:

a) More CPU efficient without avahi and bonjour running around
b) Avoid name lookup

I also had a lot of trouble with this and I found Aaron Felts post down below very useful. I found that my BBB was at 100% disk usage and I couldn’t SSH in. I was able to use the Cloud9 IDE to get in at port 3000 and use this javascript file to delete the log files and restart dropbear. After that I was able to SSH in and I then changed the journaling settings to make sure this didn’t happen again.

–Warning, this will delete your journal logs–

var exec = require(‘child_process’).exec;
function puts(error, stdout, stderr) { console.log(error); console.log(stdout); console.log(stderr); }

// 1 - Clear journal space
exec(“df -h; rm -rf /var/log/journal/; df -h”, puts);

// 2 - Remove Dropbear file
exec(“rm /etc/dropbear/dropbear_rsa_host_key”, puts);

// 3 - Stop Dropbear
exec("/etc/init.d/dropbear stop", puts);

// 4 - Start Dropbear
exec("/etc/init.d/dropbear start", puts);


Then check out this post to set journaling settings to limit disk space usage:

Hope that helps!

Thanks a lot, guys! You saved my life!!!
José Henrique

This worked for me!


I can’t seem to connect to my BBB by any means. (From Windows 8)

Tried USB, and got the directory structure, and it seems all the files are there, but all are “0” size. So obviously start,htm is blank.
It seems to me that when I first got the BBB about 2 or 3 months ago, I got it working without problems, Now I get this.
Might this be a result of the issue with unplugging?

I don’t have a mini HDMI cable so I tried by internet.But I can’t find the default IP. doesn’t work.

I can’t ssh without the IP, and I can’t get in to change or name the domain…

Any ideas?

Hi Chris.
I have the same strange behaviour. See log:

anders@anders-HP-EliteBook-8560p:~$ ssh -v root@
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/anders/.ssh/id_rsa type 1
debug1: identity file /home/anders/.ssh/id_rsa-cert type -1
debug1: identity file /home/anders/.ssh/id_dsa type -1
debug1: identity file /home/anders/.ssh/id_dsa-cert type -1
debug1: identity file /home/anders/.ssh/id_ecdsa type -1
debug1: identity file /home/anders/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/anders/.ssh/id_ed25519 type -1
debug1: identity file /home/anders/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2

The ubunto client just sits and wait forever. Strange. I have tried to delete the host key on the server and reboot but the behaviour is identical. The beaglebone otherwize seems to run without problems. Any idéas would be greatly appreciated.

/Anders V