"Unknown package" error message?

Hi, my BeagleBone arrived this afternoon, so have been having a bit of a play.

I can ssh into it with no problems, and have been trying to install a
few things, following the directions at

www.gigamegablog.com

My main problem is with Samba, when I try:-

opkg install samba

it comes back and says:-

Unknown package samba
Collected errors:
*opkg_install_cmd: Cannot install package Samba

I tried spelling samba with both upper- and lower case S, same result.

Also have the same problem with attempting to install Apache2, xinetd and swat.

Any thoughts/ideas on what I am doing wrong are welcome- I have tried
google, etc but no joy. My ultimate goal with the BeagleBone is to
have my web site running on it- nothing fancy, just static html.

have you tried 'opkg update' ?

Thanks Koen, that did the trick. I guess I just assumed as my board was brand new, it would be up-to-date.