Unreliable ethernet/U​SB connectivi​ty with Angstrom uImage-2.6​.32

Hi,

I have Angstrom Linux OS running in my Beagle board, but sometimes it is able to connect to Ethernet and sometimes not. Means out of 10 times it makes the Ethernet connection up only 2 times. Ethernet is connected through USB connector of Beagle board.
I am not sure what exactly is the issue, but I doubt that there is some issue with either kernel or the file system.

Since my Ethernet cable is connected to the USB connector of Beagle Board(through USB hub), I doubt that actually there is an issue with the USB mapping by the OS while booting.

I have attached both boot log messages (working and non-working) with this mail. if you compare both you will get idea about the issue.

Is it a known issue?
or have I done any wrong settings in Beagle Board?
Can you please help me to solve this issue?

My Configuration:

BeagleBoard Revision : B7
X-Loader : 1.41
U-Boot : 1.3.3 (Jul 10 2008 - 16:33:09)
Root file system : Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 (taken from
http://www.angstrom-distribution.org/demo/beagleboard/)
uImage : “uImage-2.6.32” taken from boot folder of the above mentioned root file system.

I made two partitions(FAT16 and EXT3) of my SD card , and FAT16 partition contains the kernel Image(uImage-2.6.32) , and EXT3 partition contains the file system(extracted Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 )

My NAND settings are :

setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait omapfb.video_mode=1024x768MR-16@60
setenv bootcmd ‘mmcinit; fatload mmc 0 0x80300000 uImage-2.6.32; bootm 0x80300000’
setenv stdin ‘serial’
setenv stdout ‘serial’
setenv stderr ‘serial’
saveenv

Thanks & Regards,
Manish

ethernet_working_log_with_kernel-2.6.32.txt (16 KB)

ethernet_not_working_log_with_kernel-2.6.32.txt (14.9 KB)

Hi,

I feel that there is an issue with the USB hub.
I use a HSB hub and provide power to it externally with some wiring. I
feel that sometimes it does not get proper power from power supply due
to loose circuitry. and that is the reason why beagleboard sometimes
does not get connected to the ethernet.

My circuitry is as below:

Ethernet wire(RJ45) -> Ethernet to USB adapter -> USB Hub -> one end
of "Female to Female USB connector"-> 5 volt power supply
Second end of "Female to Female USB connector" - > USB to OTG
connector wire-> Beagle Board USB OTG

Can anyone suggest me a proper "externally powered USB hub" which is
generally used with beagleboard(B7)? so, that I will not need to add
this circuitry for the same.

Thanks & Regards,
Manish

The revision B7 has an issue with the USB Host port. This is a very old board. You can find information on this by reading the Rev B7 System Reference Manual. http://beagleboard.org/hardware/design

Gerald

I have unreliable ethernet and usb also, but I have the BB-xM (says revA on boot, but sticker indicates revB…think they are pretty much the same anyways).

Usually, my ethernet and USB ports work the 1st time using a fresh SD card creation. After a reboot or 2, they usually aren’t even recognized during boot, or fail shorty after boot with similar messages to these:

[ 267.767883] usb 1-2: device descriptor read/64, error -71
[ 268.158630] usb 1-2: device descriptor read/64, error -71
[ 268.432037] usb 1-2: device descriptor read/64, error -71
[ 269.119323] usb 1-2: device not accepting address 2, error -71
[ 269.697753] usb 1-2: device not accepting address 2, error -71
[ 269.822723] hub 1-2:1.0: hub_port_status failed (err = -19)
[ 269.838256] hub 1-2:1.0: hub_port_status failed (err = -19)

[ 269.868530] hub 1-2:1.0: hub_port_status failed (err = -19)
[ 269.883239] hub 1-2:1.0: hub_port_status failed (err = -19)
[ 269.897857] hub 1-2:1.0: activate → -19
[ 270.603881] usb 1-2: device not accepting address 4, error -71
[ 270.885223] usb 1-2: device descriptor read/64, error -71
[ 271.150817] usb 1-2: device descriptor read/64, error -71
[ 271.448303] usb 1-2: device descriptor read/8, error -71
[ 271.612915] usb 1-2: device descriptor read/8, error -71
[ 272.291229] usb 1-2: device not accepting address 7, error -71
[ 272.305938] hub 1-0:1.0: unable to enumerate USB device on port 2

I have tried several things, but cant seem to narrow down the problem. Ive tried Ubuntu and Angstrom but no success (using a 5V wall adapter). I bought the board a little more than a year ago, so I think i just might be out of luck…

Unless anyone has some specific troubleshooting suggestions for the BB-xM?

Much appreciated,
Thank you,
Jake

You can request an RMA on it if you like.

Gerald

Gerald,

Thank you, I will request one.

Jake

Hi,

My beagleboard works fine with older version of kernel (2.6.27) and
file system(rd-ext2.bin). kenel picks this file system at boot time
and uncompress it and load it in RAM.
Ethernet works fine with this.

Can I just un-compress this file system(rd-ext2.bin) and put it in
ext3 partition of my SD card?
The problem with putting file system in RAM is that, my changes in OS
doesnot become permanent(like new user creation, setting static IP
address.....etc)

Thanks & Regards,
Manish