Unresponsive beagleboard after booting ansgtrom

Hi,

I did the following during the preparation of my SD card -

1) Setting the path, etc -
# cd linux-omap-2.6/
# export ARCH="arm"
# export CROSS_COMPILE="arm-none-linux-gnueabi"
# export PATH=/usr/local/arm/3.3.2/bin:/home/ic011998/CodeSourcery/Sourcery_G++_Lite/bin:/usr/local/arm/3.3.2/bin:/root/CodeSourcery/Sourcery_G++_Lite/bin:$PATH

2) Creating the uImage
# make distclean
# make omap3_beagle_defconfig
# make menuconfig (where I choose my config with V4L support)
# make uImage

3) Build the modules -
# make -j2 modules
# make INSTALL_MOD_PATH=/media/ROOTFS/ modules_install (my root filesystem on the SD card has been mounted to /media/ROOTFS)

4) Clean up
# sync
# umount /media/ROOTFS/
# umount /media/BEAGLE/
# e2fsck -fv /dev/sdb2

However, the problem has still not been resolved. In fact, the last two times I tried the above steps, I got the following error -

Unable to handle kernel NULL pointer dereference at virtual address 00000201
pgd = c0004000
[00000201] *pgd=00000000
Internal error: Oops: 805 [#1]
Modules linked in:
CPU: 0 Not tainted (2.6.31-omap1-05952-g945044d-dirty #1)
PC is at l4_init+0x5c/0x288
LR is at __request_region+0x58/0x90
pc : [<c001b420>] lr : [<c005088c>] psr: a0000013
sp : cf821f80 ip : cf821f90 fp : c03d9c78
r10: 00000000 r9 : 000000a5 r8 : 00000000
r7 : 00000000 r6 : c001b3c4 r5 : 00000200 r4 : 000000a5
r3 : ffffffa4 r2 : 000000ff r1 : 000000ff r0 : 000000ff
Flags: NzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment kernel
Control: 10c5387d Table: 80004019 DAC: 00000017
Process swapper (pid: 1, stack limit = 0xcf8202e8)
Stack: (0xcf821f80 to 0xcf822000)
1f80: 00000000 c03c1084 00000000 00000000 000000ff 000000ff 000000ff 000000ff
1fa0: c0019fe4 c0021bd4 00000000 c001b3c4 00000000 00000000 00000000 00000000
1fc0: 00000000 c00262a4 00000031 00000000 00000000 00000192 00000000 c0021bd4
1fe0: 00000000 00000000 00000000 c00083d4 00000000 c0027cfc 2639fd39 25dbef00
[<c001b420>] (l4_init+0x5c/0x288) from [<c00262a4>] (do_one_initcall+0x5c/0x1b4)
[<c00262a4>] (do_one_initcall+0x5c/0x1b4) from [<c00083d4>] (kernel_init+0x8c/0x
108)
[<c00083d4>] (kernel_init+0x8c/0x108) from [<c0027cfc>] (kernel_thread_exit+0x0/
0x8)
Code: e6ef4079 e893000f e88c000f e3e0305b (e5c53001)
---[ end trace 0efd7711c93ad37e ]---
Kernel panic - not syncing: Attempted to kill init!

When the OS had booted up, my serial port inputs were not detected by Angstrom. On starting the BeagleBoard, I could set the environment variables fine. But the moment Angstrom booted, the serial port would not take any inputs, and just shows me the BeagleBoard log-in screen on minicom.
Is there something wrong in the configuration file when I create the uImage? The only change I have made to the default settings is to add the multimedia drivers->video for linux support.

If there is any easier way to get my V4L-based webcam to be detected by the BeagleBoard, please do let me know.

Thanks
Regards,
Kedar