Unsupported Chip ! on custom board

hi all
we have designed our custom board using omap3530 soc…
we have booted angstrom linux through mmc card successfully , but accidently we disturbed NAND flash since then it is
not able to boot and stopping at the following stage

Texas instruments X-loader 1.4.4ss (Nov 16 2010-16:11:15)
unknown chip :mfr was 0x00, id was 0x00
Unsupported Chip !
40W

can anybody suggest what we can do to solve this problem and make it boot?

thank u

hi all
we have designed our custom board using omap3530 soc…
we have booted angstrom linux through mmc card successfully , but accidently we disturbed NAND flash since then it is
not able to boot and stopping at the following stage

Texas instruments X-loader 1.4.4ss (Nov 16 2010-16:11:15)
unknown chip :mfr was 0x00, id was 0x00
Unsupported Chip !
40W

can anybody suggest what we can do to solve this problem and make it boot?

Kiran,

The below link may help you to fix your issue.

http://www.embedinfo.com/cforum/arm_forum_moredata.asp?id=&bid=6&syid=2892

remove NAND check from x-loader

hi all
we have designed our custom board using omap3530 soc…
we have booted angstrom linux through mmc card successfully , but accidently we disturbed NAND flash since then it is
not able to boot and stopping at the following stage

Texas instruments X-loader 1.4.4ss (Nov 16 2010-16:11:15)
unknown chip :mfr was 0x00, id was 0x00
Unsupported Chip !
40W

can anybody suggest what we can do to solve this problem and make it boot?

Have seen this when the nand chip reports a unsupported chip ID to the hardcoded supported chip IDs in xloader …