Updating kernel image opkg HOWTO?

opkg upgrade kernel-image

This installed a new uImage-2.6.32 file in /boot. I tried copying this
kernel image file to the boot FAT32 partition but it doesn't boot

What do I need to do to try out a new kernel that gets pulled via opkg?

You haven't described the behavior.

I was expecting I wouldn't have to. Given the nature of the question I
expected the answer to be either:
(a) what you did is expected to work; or
(b) that's not the way to do it, you need to follow these instructions ...

Core point: is Angstrom kernel upgrade via opkg expected to work, or
not? If not, what should I be doing instead?

opkg upgraded kernel to 2.6.32 r78. The instability created is similar
to that seen when mixing the r72 uImage with the demon filesystem
(instead of using the r67(?) uImage from inside the filesystem).
Symptoms include boot hang after unpacking and USB OTG port not
working. So it seems that there is some other part of the filesystem
that also needs to be moved forward with the kernel.

Should I be updating modules too? Did the ABI change? What's behind
the instability?
I tried to avoid updating the modules as I expect this is a one-way
path: difficult to roll back to a known working system.

the kernel itself does not rely on the filesystem unless the kernel mounts it. So, if your kernel hangs right after unpacking (do you mean that a lot of dots are at console and then nothing?) then either your bootargs are absolutely wrong or the mach-type is for other machine. The latter can happen if you use u-boot for overo and try to boot beagleboard kernel.

2010/6/21 Richard Andrews <bflatmaj7th@gmail.com>

That should work, are you powering it over usb or +5V? If usb, try +5V.



Thanks everyone for the input but you are trying to solve a different problem.

Let me rephrase the question:

  How should I upgrade the Angstrom kernel? How do you personally do it?

Let's take a poll of what works.

Sub-question: is it safe to upgrade the kernel via "opkg upgade kernel-image"?

opkg update && opkg upgrade
cp /boot/uImage /media/mmcblk0p1/uImage ; sync

I tried. It got a couple hundred MB through and opkg segfaulted. I
wasn't watching at the time. Maybe OOM.

In a parallel effort I'm now trying the OpenEmbedded recipes.