Upgrade runtime on beaglebone

I have searched for too long and can’t find a solution.

I have a beaglebone black revc and I need to update the c++ runtime to support something greater then glib 4.7. I have 4.9 and 5.1 on my machine that i build and deploy from, but I don’t have 4.7 and I am using features of these compiles that I get the message:

/usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version ‘CXXABI_1.3.8’ not found (required by MyDaemon);

looking at strings for this lib indicates it supports up to 1.3.6 but not 1.3.8

glibc 4.9 supports 1.3.8 as does the 5.x versions.

Any guidance would be appreciated.