USB being incompletely responsive

After installing a few packages on ubuntu bbb and modifying my environment (screen, bash, etc), I tried plugging in a usb device again and it wasn’t read.

I then logged off, took out and reinserted power (all coming from laptop) only to find that now, while the usb was being seen, it wasn’t doing anything - the device connected has a light that turns on but it wasn’t on.

I checked the system profiler and found that while there was 500mA available, only 2 was required (I’m guessing this means requested). So it seemed like even though the usb was found (see lsusb results below), it wasn’t being given power:

ubuntu@arm:~$ lsusb
Bus 001 Device 002: ID 05e3:0510 Genesys Logic, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So I went through a bunch of posts on the forum. There was a suggestion to boot up with the usb attached. So I unplugged the usb, took out the power, plugged in the usb, and then rebooted. Still didn’t work. Previously, I had had a problem with usb hotplugging (as I suppose everyone has had), but thought that it was fixed with Ubuntu Raring.

Even worse - now, ethernet isn’t working.

Anyone have any suggestions? Is there a tried-and-true method for getting ethernet and usb running at the same time?

So, after unplugging everything, turning off (holding down pwr button until off) and going to get some food, I decided to try again. This time the usb is working (and I’m not taking it out), but the ethernet is just refusing to receive data. I’ve put dmesg and ifconfig below. Is it the case that I can’t run a usb device and ethernet at the same time? That would be strange to me, so I’m mostly discounting it, but I can’t understand why this ethernet port is so fickle.

ubuntu@arm:~$ dmesg | tail
[ 16.225648] init: plymouth-stop pre-start process (776) terminated with status 1
[ 16.423276] gadget: sending command-failure status
[ 17.507028] usb0: eth_open
[ 17.507078] usb0: eth_start
[ 17.507289] gadget: rndis_open
[ 17.507322] rndis_set_param_medium: 0 4259840
[ 548.297541] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 548.297711] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 778.508516] lun0: unload attempt prevented
[ 778.508576] gadget: sending command-failure status

ubuntu@arm:~$ ifconfig
eth0 Link encap:Ethernet HWaddr c8:a0:30:b4:5c:78
inet addr: Bcast: Mask:
inet6 addr: fe80::caa0:30ff:feb4:5c78/64 Scope:Link
RX packets:202 errors:0 dropped:0 overruns:0 frame:0
TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:41644 (41.6 KB) TX bytes:1968 (1.9 KB)

I would like to make the general statement that I don’t think anyone should use the host USB port when the system is being powered over the client USB port. I have seen several people that don’t have any issue with doing so, but I have also seen several people that do have difficulty. The client USB port is really quite touchy, and one interesting thing is that you’re probably not grounding your BBB the same way as you would by using a power supply via the barrel connector. I’ve noted USB babble interrupts before when I’ve simply picked up a USB gamepad that is plugged into the host port. So, as the first troubleshooting step, you can try using a 5VDC, 2A power supply though the barrel connector. Or, if you already have one around, plug a powered USB hub into the host port and then plug your ethernet into the powered hub. I think that your hardware is being “fickle” not because of just power draw, but also because you don’t have much of a ground on your BBB.