USB collapse on BeagleBone A5 and A6

Hello,

I am having a severe USB-issues on my BeagleBone’s and my own debugging attempts have led me nowhere. My machines are equipped with one D-Link H7 USB HUB, four 3G modems and one USB 10/100-Ethernet dongle. If I only use the 3G modems, everything is fine. Also, if I only send a little bit of traffic over the USB Ethernet, everything behaves as it should. However, if I send a lot of data over the USB Ethernet (push the dongle really hard), the whole USB subsystem seems to collapse and weird things start happening. Events I have observed are (multiple might happen at the same time):

  • The transfer over the USB Ethernet dies (i.e., no data is received).
  • One or more of the 3G modems go down. However, this is not detect properly by the system and for example pppd is not stopped (as it normally is when a modem goes down).
  • The previous happens and pppd is stopped, but I get write timeout to the serial devices.
  • USB add/remove events are not detected. I.e., lsusb outputs the same no matter if I have connected or disconnected devices.
  • The kernel starts reporting USB errors related to the hub (error -110, suggests the cable is bad, so on). The hub works perfectly after reboot.

In order to rule out power issues, I daisy-chained the powered USB hubs, but with no luck. I also see this behavior if I only use the USB Ethernet dongle. However, I do not believe it to be the dongles fault as this also occurs when I try to use WLAN-dongles and also different Ethernet-dongles. Also, the Ethernet-dongles I have tried (as well as WLAN) work perfectly on my laptop and desktop (runnung Ubuntu 12.04). I have also tried other USB hubs, but with the same issue.

The issue occurs on both rev. A5 and A6, and have been present in all kernels I have found (the boards are currently running psp22).

If anyone has any tips on how to advance or solve this, it would be greatly appreciated!

Thanks in advance,
Kristian