USB conenction donot show up with pocket beagle

I have tried the latest debian image as well as TISDKImage with pocket beagle from microsdcard. Both images boot and I connect a serial cable and can see root login and looked at
IP address and pocket beagle did have an IP of 192.168.7.2 . But neither in linux or in windows 10, USB shows up. So i cannot get a network connection. What is missing here?

Went back to 2018 version and tried two different pocket beagle boards. No luck. Doesnt show up USB on ubuntu 14 LTS machine or a windows 10?
What is missing? is there a support group for this device? anyone ?

Hi Hanah,

Are you saying you cannot see the Beaglebone drive letter appear on the Windows PC, and that ipconfig /all does not show the network interface?
If that is occurring with two different images, but it appears to boot up fine via serial, then it sounds like a USB cable or connector issue. Some cheap cables are only intended for charging, and may not have all four wires internally connected. If another USB cable doesn’t work, you may wish to test with another PocketBeagle to eliminate some hardware issue.

Thank you, yes usb cable was the issue