USB HOST port not working - Rev C2 board

Hi,

For the last couple of days I've been trying to get the USB HOST port
to work on my Beagle Board (Rev C2). I'd rather use it than the USB
OTG port to connect a keyboard and mouse.

I've used all the kernel version I can think of, but none seem to
work. E.g. http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation
set-up gives me the following EHCI stuff at the boot:

Your u-boot is a know broken version, try 2009.06rc or 2009.08. You can find 2009.08 at http://www.angstrom-distribution.org/demo/beagleboard/

regards,

Koen

I tried the "U-Boot 2009.08 (Oct 20 2009 - 13:09:07)" from the
Angstrom site as well as few others from various other ports.
Unfortunately it didn't make a difference and I still get the "hub
1-0:1.0: unable to enumerate USB device on port 2" error.

Regards,
Ari

Hi Ari,

I found I needed to apply this patch:
http://www.beagleboard.org/gitweb/?p=linux-2.6.git;a=commitdiff_plain;h=4c79dd4e88c57a860692eb23864b3f2030d6d459

To get the EHCI USB port working; the version of u-boot didn't matter
(for me).

Also you need to ensure you use a USB 2.0 HUB; attaching USB 1.0
device directly to the EHCI port doesn't work.

The kernels I've used should have this patch. E.g. the Maemo5 kernel:
http://gitorious.org/maemo5-sgx-beagle/maemo5-beagle-cvm/blobs/master/arch/arm/mach-omap2/board-omap3beagle.c#line217

I've tried various different kernels & rootfs from
http://www.angstrom-distribution.org/demo/beagleboard/ as well, but
still no dice. Just the "unable to enumerate USB device" and no mouse
and keyboard.

Regards,
Ari