USB power and Hotplug problem


I’ve been working with USB Hub from Texas Instruments (TSUB2046BVF) and i’ve tried to plug it to my BBB and everything works fine if i plug devices before BBB boot up but when i unplug and plug again (hotplug) it is not recognized.

Based on some forum posts I realized that this is a Software problem on the BBB, so my question is if there’s any new update or some workaround to solve this problem?

Another question is regarding the power using only the USB, is there any current restrictions during BBB boot up? because if i power some HW to BBB 5V (consuming about 150mA) the BBB does not boot.

Thanks in advance.

Duarte Carona

Yes, there is a current restriction on boot up. It is part of the USB standard and imposed by the PC. 100mA max until the ports is recognized by the PC.


Well, the usb spec gives you "only" 100mA till you request more. So I
don't see that design booting off a "standard" usb port any time soon.



Thank you for the response.

The boot issue i’ve solved it with a soft start circuit and now it is working.

The hot plug problem, i’m still struggling to find a solution because i can’t find one, is there any suggestions to solve it?


Duarte Carona

Terça-feira, 27 de Maio de 2014 15:33:04 UTC+1, RobertCNelson escreveu:

Boot the board with your hub connected and after boot run the commands below, then test hot-plug.
echo on > /sys/bus/usb/devices/usb1/power/control
echo on > /sys/bus/usb/devices/usb1/1-1/power/control


I’ve already solved the problem. I simply made an update and upgrade to my BBB ant it solved the problem. Now i can plug and unplug my devices and they are recognized by the BBB.

I discovered that some releases of Angstrom has that problem, I’ve tried a few and some have and others don’t, now i’m using the release from September 2013 and it’s working.

Thanks for the tips and for the replies.

Duarte Carona

Quarta-feira, 28 de Maio de 2014 19:30:51 UTC+1, cody escreveu: