usb to ethernet interface problem

Hi,

I am working with beagle board and angstrom distribution.

i have connected ethernet cable though dm9601 usb to ethernet
connector.

i have enable the driver for dm9601 in kernel.

but i cant get ip.

if i give the command "ifconfig eth0" i got the below error

ifconfig: eth0: error fetching interface information: Device not found

or

ifconfig: SIOCSIFADDR: No such device

could please help me regarding on that?

With Regards,
Thangaraj.P

See if it gets enumerated "lsusb", also check "dmesg|less" for errors.
root@beagleboard:~# dmesg|grep eth
[112866.721313] pegasus 1-2.2:1.0: eth0, ADMtek ADM8515 "Pegasus II"
USB-2.0 Ethernet, 00:60:70:01:3e:43

Regards
Sid.

I had the same problem before my bb burned (for a completely different reason of course!). USB device was detected as far as dmesg shows, but, I couldn’t see any device except ‘lo’ when I do ‘ifconfig -a’. I couldn’t see any obvious errors in the log.

Sid,
There was no ‘lsusb’ in the busybox that I compiled. Where did you get it from?

Thanks,
–Krishna/.

hi ,

there was no lsusb command.

where we have to enable in the distribution?

I had the same problem before my bb burned (for a completely different
reason of course!). USB device was detected as far as dmesg shows, but,
I couldn't see any device except 'lo' when I do 'ifconfig -a'. I
couldn't see any obvious errors in the log.

Sid,
There was no 'lsusb' in the busybox that I compiled. Where did you get
it from?

Thanks,
--Krishna/.

OK, sorry it's in "unstable", "cat /proc/bus/usb/devices" gives the same
info.
Regards
Sid.

hi ,

there was no lsusb command.

where we have to enable in the distribution?

It's in koen's unstable branch, sorry - "cat /proc/bus/usb/devices" in
the standard distribution.
Regards
Sid.