usb wifi issues - rfkill won't unblock interface?

I’ve got a BeagleBone running 3.2.16, hoping to get a system running that supports both wifi and PWM capabilities. I’ve got a rt2800usb adapter and a Belkin that seems happy with the zd1211rw drivers. Both prompt a wlan0 entry to show up in iwconfig’s output when they’re plugged in.

I’ve set up wpa_supplicant.conf like so:

wpa_passphrase my_ssid “my_passphrase” > /etc/wpa_supplicant.conf

Unfortunately I’m now stuck. Both ifup wlan0 and wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf deliver identical error messages:

Could not set interface wlan0 flags: Operation not possible due to RF-kill
Failed to initialize driver interface

Googling turns up threads like this one: http://comments.gmane.org/gmane.comp.hardware.beagleboard.user/31619 which make it sound like I need to use rfkill to break the lock. The /dev/rfkill device existed; I built the command line tool (v0.4 from linuxwireless.org). rfkill list shows:

0: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no

rfkill unblock 0 or rfkill unblock all both seem to return fine. But the state displayed by rfkill list remains the same. And the same error is returned by wpa_supplicant and ifup (well, the latter only if I do an ifdown first – otherwise it returns an error about the device already being configured).

Other miscellaneous notes: I’ve done a full opkg upgrade. I’ve tried both enabling and disabling WiFi in /var/lib/connman/settings (it’s normally disabled), which changes the error message to one about wlan0 being a file/device that’s not found. I’m guessing it’s best to leave it disabled and keep connman out of all of this.

Any ideas? Help would be greatly appreciated – I’ve been wrestling to get both wifi and PWM working simultaneously off and on for months now.

Tom

Hello Tom!
I have the same problem … To make it work I put the image of Ubtuntu Need. I do not know what happens, I believe to be some setting in the image Ansgtrom, but nobody can tell me what it is.

If interested in putting Ubuntu follow these steps to configure the WLAN:
http://ubuntuforums.org/showthread.php?t=202834
Need To Install Ubuntu, download:
http://rcn-ee.net/deb/rootfs/precise/ubuntu-12.04-r1-minimal-armhf.tar.xz
and then follow the steps: (http://elinux.org/BeagleBoardUbuntu)

  1. Unzip the image;
  2. Use->>>> . / Setup_sdcard.sh - mmc / dev / sdX - Uboot bone

Thanks, Nilson! I would hate to have to abandon Angstrom after spending so much time working on it, but perhaps I’ll have to. Do you know if PWM and GPIO work properly on the BeagleBone with Ubuntu?

GPIO works the same way. I have tested. Part of PWM I do not know …
But I believe it works the same.
If you want I can do some test to verify this.

Just install the latest angstrom image, that has working wifi.

Hello Koen!
I installed the latest version of the image Angstrom. I had the wlan0 recognized, but not connected with the settings I made. Do you have any recommendation to make to set the image Angstrom? I would prefer to work with the Angstrom image …

Hello Koen!
I installed the latest version of the image Angstrom. I had the wlan0 recognized, but not connected with the settings I made. Do you have any recommendation to make to set the image Angstrom? I would prefer to work with the Angstrom image ...

have a look at http://ladyada.net/products/beaglebone/wifi.html

I did exactly as in this tutorial and it did not work. Gave the same error.

As did I, with the USB WiFI device purchased from AdaFruit. No dice. Just to be clear, this is with [Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.05.09.img.xz](http://downloads.angstrom-distribution.org/demo/beaglebone/Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.05.09.img.xz)

Correct?

*Brian