Using Connman for WiFi AP/tether...

Hi Brian,
Do you know how to ConnMan to create a access point without password? is ConnMan suport that ?

在 2016年3月10日星期四 UTC+8上午3:10:44,Brian Anderson写道:

在 2016年3月10日星期四 UTC+8上午3:05:47,Brian Anderson写道:

Do you know how to ConnMan to create a access point without password? is ConnMan suport that ?

Unfortunately, no. Connman requires a passphrase. In fact, the passphrase must be at least 8 and no more than 63 characters. You can see this in the source code (technology.c, line 926).


Hi Brian,
Do you know what’s the technology ConnMan tether used ? I didnt find any hostapd code. but a lot of wifi driver only suport hostapd. is there a way modify the ConnMan wifi plugin and suport ConnMan /

在 2016年3月12日星期六 UTC+8上午2:01:35,Brian Anderson写道:

Drop dnsmasq/create_ap, add back udhcpd

Just curious, why udhcpd rather than dnsmasq? Isn’t dnsmasq supposed to be “light weight”? Err, lighter than udhcpd? What is the difference between the two?

Robert, what was the reason here? It would be great if we could reduce the number of tools and simply do bug fixes ourselves to try to push things across the finish line. Right now, I’m in networking hell. :frowning:

I presume you
have told Connman to ignore usbx interfaces in /etc/connman/main.conf?

Here’s the configuration i’m using at the moment, i’ll test adding an
ignore for usbx

Hmm, I see you are ignoring usb0 rather than all usb interfaces. I suppose that is the only possiblity on BBB. Not sure about other boards.

I keep seeing funky behavior where I ask connman to ignore interfaces and it still prints a bunch of stuff and seems to interfere. I’ve added ‘SoftAp’ to the ignore list so we could create a wifi gateway and if I have connman running, even though it says it is ignoring the interface, it gives me an odd issue with the name already being used.

BTW, does it work to put a USB hub between the host and gadget and thus connect multiple hosts (laptop, desktop, etc.) to the usb ethernet and thus serve up many IP addresses from usb0 gadget?

With the BeagleBone acting as the DHCP server and repeatedly serving up the same address, that wouldn’t work. We need a minimal host configuration setup on all of Windows, Linux and Mac, so I think asking people to manually configure their networks isn’t a scalable approach.

So dnsmasq was creating havok on usb0. Connman tethering worked cleanly on
both usb0 & wlan0.. BUT, connman wouldn't allow us to use "192.168.7.x" for
usb0, there is no config option to specify ip address ranges. I didn't
want to break all the docs that said to connect over ""..

Thus connman was used for wlan0 and usb0 for udhcpd..


Dear all,

I have to warm up this post again as I’m dealing with a minor problem when setting my boards in AP mode:

I have two BBBs: 1 BBBW and one BBB rev. C

On BBBW (4.4.30-ti-r64) the AP is started automatically, I can use /var/lib/connman/settings file to set the SSID and the passphrase, and I can connect to this board and get an IP in the range of 192.168.0.X

On BBB with a TP-Link TL-WN722N (4.4.91-ti-r133) I try to do the same. Therefore, I uncommented to connman line in /etc/network/interfaces and edited the /var/lib/connman/settings (same setting as above). When I restart the board I can see the SSID and even connect (from Windows) but I don’t get an IP. → So I think I have to change another small thing to get it working 100% (a problem with the DHCP?). Can you please point me towards the right direction??? Would be great!

Best regards,

Give this a shot:

sudo connmanctl tether wifi on ${wifi_ssid} ${wifi_password}


Dear Robert, all,

thanks for your response.

I tried your command (without luck):

"Wifi SSID set

Wifi passphrase set

Enabled tethering for wifi (if I stopped to already running tethering using connmanctl tether wifi off)


Error enabling wifi tethering: Already enabled"

In the first setup, I can again connect to the board via WiFi (Windows) but I don’t get an IP address. Any ideas what else to do/try?

(I also cloned the eMMC from my BBBW (i.e., where the setup is up and running) to an SD card, flashed it to a second BBB with connected TL-WN722N, and also here it works “out-of-the-box”. So it don’t seems to be a problem of the used HW)

Related question: can you guys point me to the file / configuration where the IP range (192.168.0.X) is set? As I’m planning to run several networks in parallel it would be good to have different IP ranges in use.

Best regards and thank you very much,