Using mplayer to stream video from security camera

Hello,

I am using a Hauppauge USB-Live 2 device to convert a composite video stream into USB so that I can display the video on the BeagleBone Black. So far, I have not had much luck. I have tried various video output formats, but the only one that seems to “work” is fbdev2. However, the only thing I see on my LCD is a green screen. I have searched several of the errors that are shown below, but have not turned up much so far. Does anyone have any suggestions on what I should try next?

root@beaglebone:~# mplayer -vo fbdev2 tv:// -tv driver=v4l2:device=/dev/video0:input=0
MPlayer2 2.0-379-ge3f5043 © 2000-2011 MPlayer Team
162 audio & 361 video codecs

Playing tv://.
Detected file format: TV
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come :wink:
Selected device: Hauppauge USB Live 2
Capabilities: video capture VBI capture device audio read/write streaming
supported norms: 0 = NTSC; 1 = NTSC-M; 2 = NTSC-M-JP; 3 = NTSC-M-KR; 4 = NTSC-;
inputs: 0 = Composite1; 1 = S-Video;
Current input: 0
Current format: YUYV
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
Selected input hasn’t got a tuner!
Opening video filter: [scale]
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[ass] auto-open