Using pico DLP with BBB

Has anyone had success in getting a pico DLP to work with a BBB running Angstrom?

I’ve plugged mine in and the display is trying to show something, but it looks like the timing is wrong. I’m running the 3.8.13 version of the kernel. The edid seems to know it’s a pico (see below)

How do I set the resolution to the native 480x320?

–Mark

parse-edid /sys/class/drm/card0/card0-HDMI-A-1#/edid
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:10

Block type: 2:0 3:10

Block type: 2:0 3:fc

Identifier “YOI Pico”
VendorName “YOI”
ModelName “YOI Pico”

Block type: 2:0 3:10

Block type: 2:0 3:10

Block type: 2:0 3:fc

DPMS capabilities: Active off:no Suspend:no Standby:no

Mode “640x480” # vfreq 62.648Hz, hfreq 31.888kHz
DotClock 25.000000
HTimings 640 648 744 784
VTimings 480 482 484 509
Flags “-HSync” “-VSync”
EndMode

Block type: 2:0 3:10

Block type: 2:0 3:10

Block type: 2:0 3:fc

You don't... As the last time i looked (2 years ago), you could not
bypass the internal video down-scalar...

Regards,

Is the downscalar on the pico side?

Is there some uEnv.txt magic I can do on the BBB side to get the pico to work?

–Mark

optargs=video=HDMI-A-1:640x480@60

Should work...

Regards,

That did it. It’s now working! Thanks…

–Mark

I did not find that kind of option in the documentation looking for uEnv.txt options, eg

http://git.denx.de/?p=u-boot.git;a=blob;f=include/configs/am335x_evm.h;hb=HEAD#l57

I am actually looking for the option that forces hdmi to ignore messages about the display it is connecting to,
in raspberry pi it is called
hdmi_force_hotplug=1
or

hdmi_safe=1

see
http://elinux.org/R-Pi_Troubleshooting#No_HDMI_output_at_all

These options made it possible for the raspberry to drive a DVI display which via a hdmi-dvi adaptor that did not pass the correct info to the raspberry.

Is there such an options in uEnv.txt for the beagles?

I did not find that kind of option in the documentation looking for uEnv.txt
options, eg

http://git.denx.de/?p=u-boot.git;a=blob;f=include/configs/am335x_evm.h;hb=HEAD#l57

Those variables are not written in stone...

But in our case, its there...
http://git.denx.de/?p=u-boot.git;a=blob;f=include/configs/am335x_evm.h;hb=HEAD#l65
We just used the "optargs" aka optional arguments, as a way to pass
the video info to the kernel..

optargs=video=HDMI-A-1:640x480@60 -> kernel sees: video=HDMI-A-1:640x480@60

Which the 'drm' uses modedb.txt:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/fb/modedb.txt

I am actually looking for the option that forces hdmi to ignore messages
about the display it is connecting to,
in raspberry pi it is called
hdmi_force_hotplug=1
or

hdmi_safe=1

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/fb/modedb.txt#n41
adding an "e" at the end should force it on now matter what.. so::
optargs=video=HDMI-A-1:640x480@60e

see
http://elinux.org/R-Pi_Troubleshooting#No_HDMI_output_at_all

These options made it possible for the raspberry to drive a DVI display
which via a hdmi-dvi adaptor that did not pass the correct info to the
raspberry.

Is there such an options in uEnv.txt for the beagles?

Regards,