using TIs EZSDK platforms

can someone kindly let me know if I can use these images(## LINUXEZSDK-AM335X)#

installed on my beaglebone? if not, may I know why?

thank you

Yeah you can I just got that working yesterday, actually. They have a wiki but it’s specific to the white. I wrote one up for the black here:

Note that this image will result in no HDMI. no LED activity, based on 3.2 kernel, and requires a USB to serial adapter. That may put it into the “Why not” category.


If you dont mind, can you explain the difference between these linux images and notmal linux image that comes along with Beaglebone?
Can we talk of one thats better?

The one that ships with the board is better. That is the one we support and why we use it. It has community support

The SDK is based on an old kernel. It has no HDMI support. No LEDS for status. Very basic functionality. Only reason to use it is if you need 3.2 kernel support. Supported by TI.

You also have a few more options as well. to possibly consider.


i've been directed to that link before, but it doesn't explain how
the currently shipping image is created. is that recipe somewhere
online or not? this seems like a fairly simple question.


Not sure how the EZSDK image is created.



I'm sure you've seen, which is how the EZSDK
image is created. I'm not sure which particular recipe/tag is used,
but I believe the kit itself includes the meta-information used to
build it.


I believe he was talking about the Angstrom image. There is another thread discussing that ( )

I used the prebuilt kernel in the LINUXEZSDK-BBONE but it hung at boot. Do I need to really follow the procedure in Tommy’slink above:

What I HAD done to verify system was to

  1. interrupt boot
  2. set ipaddr, serverip
  3. tftp boot Angstrom kernel to 0x82000000
  4. tftpboot am335x-boneblack.dtb to 0x80f80000
  5. setenv bootargs console=ttyO0,115200n8 root=/dev/nfs nfsroot= rw ip=
  6. bootm 0x82000000 - 0x80F80000

This booted OK on BBB but when I changed [ only ] to the ti kernel it hung after “booting the kernel”.

What might I be missing? Thanks I’m new to this here - Doug

Yes, you need to really do as Tommy says. And make sure you have the latest version of the EZSDK and have a serial cable attached.


That worked, THANKS all.

However, I had to, after finished, mount the card on my host and copy uEnv.txt ( as generated from ) to the fat partition.


Great! I will pass it to Tommy and have him double check that last part.


Well, because the SDK is really only specific to the AM335X processor it doesn’t initially create a uEnv.txt during the first sd card creation. The SDK is made to work on the EVM as well and that doesn’t require a uEnv.txt. After you boot from the sd that is created you should run that “” script. While you’re going through that it should recognize that you have connected a Beaglebone. If I remember correctly, it adds a uEnv.txt file at that point.


Hi Tommy,

I’m using BBBlack and ti-ezsdk_dm816x_evm_5_05_02_00 so I have some trouble.
Firstly I installed it and saved the sd_card. But when I tried to connect pc or hdmi , I can’t see anything. I looked in BOOT but did not see uEnv.txt . So how would I solve this problem?


12 Temmuz 2013 Cuma 20:55:32 UTC+3 tarihinde Tommy Snyder yazdı: