Using uart1 rts and cts

I am using uart 5 with hardware flow control quite happily.

As I don’t have any hardware cape installed, I thought that I would be able to use uart 1 – while I would be remuxing both i2c2 pins, my reading of the documentation was that with no cape installed, that would be OK.

But I wasn’t able to get that working – while uart 1 worked without hardware flow control, as soon as I enabled cts/rts I couldn’t transmit through the port.

Using uart 5 instead is OK, but I’m curious as to why uart 1 rts/cts wouldn’t work?


How about providing some info? Such as:
$ cat /proc/tty/driver/OMAP-SERIAL
$ stty -F /dev/ttyO1 -a
$ dmesg | grep capemgr
Maybe you need to tweak the port settings a bit? For example, stty clocal (I believe that disables DTR/DSR/CD, but I’m not totally sure).


I do have the same issue. I want to use the RTS Pin for UART1.
I already tried to teak the uart with stty like
stty -F /dev/ttyO1 clocal
stty -F /dev/ttyO1 -hupcl
cat /proc/tty/driver/OMAP-SERIAL shows
1: uart:OMAP UART1 mmio:0x48022000 irq:89 tx:1036 rx:4367 brk:1 RTS|CTS|DTR|DSR|CD|RI

but for example avrdude can not reset the UART device.

Tom did you get it running?

I haven’t really looked too hard, but my first guess would be that in uEnv.txt you would need to disable i2c2 pinmux like what is done with hdmi/emmc when you don’t want that. On 3.12.6 kernel I had to actually remove pinmux for hdmi before I rebuilt the kernel.

Which name should I use? Only i2c2 does not work…