Uubuntu/Robert Nelson's image and /opt/boot-scripts

To make a clean start of things, I’m reformatting my SD cards using Robert Nelson’s latest image creation tool to make sure all my uBoot files are using his layout, as well as my Ubuntu config.

I noticed the comment about how to disable the “active on Boot script” so I dig some digging into the /opt/bootscript directory.


ubuntu@arm:/opt/boot-scripts$ ls -la
total 40
drwxr-xr-x 3 ubuntu ubuntu 4096 Sep 20 10:45 .
drwxr-xr-x 8 ubuntu admin 4096 Sep 19 16:28 …
-rwxr-xr-x 1 ubuntu ubuntu 2408 Aug 24 19:55 am335x_evm.sh
-rwxr-xr-x 1 ubuntu ubuntu 446 Aug 24 19:55 BEAGLEBOARD_XM.sh
-rwxr-xr-x 1 ubuntu ubuntu 2408 Aug 24 19:55 BEAGLEBONE_A.sh
-rwxr-xr-x 1 ubuntu ubuntu 2408 Aug 24 19:55 BEAGLEBONE.sh
-rwxrwxr-x 1 ubuntu ubuntu 339 Sep 20 10:45 fix_ssh_host_key.sh
drwxr-xr-x 8 ubuntu ubuntu 4096 Sep 20 10:45 .git
-rwxr-xr-x 1 ubuntu ubuntu 446 Aug 24 19:55 omap3_beagle.sh
-rwxr-xr-x 1 ubuntu ubuntu 763 Aug 24 19:55 set_date.sh


[Note: fix_ssh_host_key.sh was not there initially, but I noticed the hidden .git directory so I ran a git pull and brought it up to date with the current repository]

I’m curious on what will cause set_date.sh and fix_ssh_host_key.ssh to run. As near as I can tell, only one file will be run from this directory, the one which matches your board.

Should I just edit the bootscript that is being run to call those two files as well?

Well set_date.sh is run by:

/etc/init/boot_scripts.conf (in ubuntu)

while i'm still not happy with the way fix_ssh_host_key.sh runs so
nothing calls it yet. (the idea it should only be run once..)


I drop an init script into /etc/init.d that removes itself once it runs: