uvcvideo ?

Hi all

I am using the Beableboard-xM and Beaglebone Black-C.
Both are using the ubuntu-14.04-console-armhf-2014-08-13 as OS.
When each board is connected to a Logitec C270 and used to distribute video using mjpg-streamer,
Beaglebone Black can distribute the pipeline even without y option, but the Beagleboard-xM doesn’t distribute anything without the y option of mjgp-streamer.

Why do the two boards act differently?

version of uvcvideo is the same 1.1.1

log of connected the web camera are as follows

Beaglebone Black
usb 1-1.4: unregistering device
usb 1-1.4: unregistering interface 1-1.4:1.0
usb 1-1.4: unregistering interface 1-1.4:1.1
usb 1-1.4: unregistering interface 1-1.4:1.2
usb 1-1.4: unregistering interface 1-1.4:1.3
usb 1-1.4: usb_disable_device nuking all URBs
hub 1-1:1.0: debounce: port 4: total 100ms stable 100ms status 0x100
hub 1-1:1.0: state 7 ports 4 chg 0000 evt 0010
hub 1-1:1.0: port 4, status 0101, change 0001, 12 Mb/s
hub 1-1:1.0: debounce: port 4: total 100ms stable 100ms status 0x101
usb 1-1.4: new high-speed USB device number 5 using musb-hdrc
usb 1-1.4: skipped 1 descriptor after configuration
usb 1-1.4: skipped 8 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: skipped 43 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: skipped 4 descriptors after interface
usb 1-1.4: skipped 2 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: skipped 2 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: skipped 2 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: skipped 2 descriptors after interface
usb 1-1.4: skipped 1 descriptor after endpoint
usb 1-1.4: default language 0x0409
usb 1-1.4: USB interface quirks for this device: 2
usb 1-1.4: udev 5, busnum 1, minor = 4
usb 1-1.4: New USB device found, idVendor=046d, idProduct=0825
usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=2
usb 1-1.4: SerialNumber: 4B254210
usb 1-1.4: usb_probe_device
usb 1-1.4: configuration #1 chosen from 1 choice
usb 1-1.4: adding 1-1.4:1.0 (config #1, interface 0)
uvcvideo 1-1.4:1.0: usb_probe_interface
uvcvideo 1-1.4:1.0: usb_probe_interface - got id
uvcvideo: Found UVC 1.00 device (046d:0825)
input: UVC Camera (046d:0825) as /devices/ocp.3/47400000.usb/musb-hdrc.1.auto/usb1/1-1/1-1.4/1-1.4:1.0/input/input2
usb 1-1.4: adding 1-1.4:1.1 (config #1, interface 1)
usb 1-1.4: adding 1-1.4:1.2 (config #1, interface 2)
snd-usb-audio 1-1.4:1.2: usb_probe_interface
snd-usb-audio 1-1.4:1.2: usb_probe_interface - got id
usb 1-1.1: kworker/u:0 timed out on ep0out len=0/4
usb 1-1.4: khubd timed out on ep0out len=3/3
ALSA sound/usb/clock.c:228 5:3:2: cannot set freq 24000 to ep 0x86
usb 1-1.1: kworker/u:0 timed out on ep0in len=0/4
usb 1-1.4: khubd timed out on ep0out len=3/3
ALSA sound/usb/clock.c:228 5:3:3: cannot set freq 32000 to ep 0x86
usb 1-1.1: kworker/u:2 timed out on ep0in len=0/4
usb 1-1.4: khubd timed out on ep0out len=3/3
ALSA sound/usb/clock.c:228 5:3:4: cannot set freq 48000 to ep 0x86
ALSA sound/usb/mixer.c:1299 usb_audio: Warning! Unlikely big volume range (=6144), cval->res is probably wrong.
ALSA sound/usb/mixer.c:1303 usb_audio: [5] FU [Mic Capture Volume] ch = 1, val = 1536/7680/1<7>[354449.897676] usb 1-1.4: adding 1-1.4:1.3 (config #1, interface 3)

Beagleboard-xM
usb 2-2.2: USB disconnect, device number 6
usb 2-2.2: new high-speed USB device number 7 using ehci-omap
usb 2-2.2: New USB device found, idVendor=046d, idProduct=0825
usb 2-2.2: New USB device strings: Mfr=0, Product=0, SerialNumber=2
usb 2-2.2: SerialNumber: 4B254210
uvcvideo: Found UVC 1.00 device (046d:0825)
input: UVC Camera (046d:0825) as /devices/68000000.ocp/48064000.usbhshost/48064800.ehci/usb2/2-2/2-2.2/2-2.2:1.0/input/input5
usb 2-2.2: set resolution quirk: cval->res = 384