virtual mouse driver

Hi,

We are facing issue as mouse pointer is not moving while sending
virtual mouse coordinate to user space via sysfs. We already tried
uInput it is working fine.

system Requirement:
Board : BeagleBoard Xm
OS : Ubuntu

We tried creating a virtual mouse driver as part of my input driver
based on study (essential linux drivers book chapter 7). Besides the
driver, there is also a user application (coord.c) that generates
random coordinates and forwards these coordinates to the driver via
sysfs.

In Logcat it shows:

[ ]input: Unspecified device as /devices/virtual/input/input8
[ ]Virtual Mouse Driver Initialized.

We tried running gpm as follows : gpm -m /dev/input/eventX -t evdev

$ cat /proc/bus/input/devices
I: Bus=0019 Vendor=0000 Product=0002 Version=0000
N: Name="Power Button (FF)"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
U: Uniq=
H: Handlers=kbd event0
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1
U: Uniq=
H: Handlers=kbd event1
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input2
U: Uniq=
H: Handlers=mouse0 event2
B: EV=7
B: KEY=
B: REL=3

we are unable to proceed further,