VRAM Setting For Angstrom

Hi All,

For increasing the VRAM in Angstrom I tried multiple bootargs like
setenv bootargs ‘console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait omapfb.mode=dvi:1024x600MR-16@60 vram=32M omapfb.vram=1:8M,2:8M’

setenv bootargs ‘console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rootwait rootfstype=ext3 rw omapfb.vram=0:8M omapfb.mode=dvi:640x480MR-16@60’

But the VRAM is remain as default (1.4MB)

So can you suggest me the Proper Bootarg.
I tried with adding omapfb.debug=yes
And the output of dmesg is

[ 70.820800] PVRSRV_PIXEL_FORMAT_RGB565
[ 71.632537] OMAPFB: Closing fb with plane index 0
[ 71.992706] OMAPFB: pan_display(0)
[ 71.992736] OMAPFB: setcmap
[ 71.992767] OMAPFB: setcmap
[ 72.005554] OMAPFB: check_var(0)
[ 72.005584] OMAPFB: check_fb_var 0
[ 72.005615] OMAPFB: max frame size 1474560, line size 2048
[ 72.005615] OMAPFB: xres = 1024, yres = 720, vxres = 1024, vyres = 720
[ 72.005645] OMAPFB: set_par(0)
[ 72.005645] OMAPFB: set_fb_fix
[ 72.005645] OMAPFB: apply_changes, fb 0, ovl 0
[ 72.005676] OMAPFB: setup_overlay 0, posx 0, posy 0, outw 1024, outh 720
[ 72.005767] OMAPFB: pan_display(0)
[ 72.005767] OMAPFB: setcmap
[ 72.005859] OMAPFB: pan_display(0)
[ 72.005859] OMAPFB: setcmap
[ 72.005889] OMAPFB: setcmap
[ 72.018432] OMAPFB: setcmap
[ 72.041748] OMAPFB: Closing fb with plane index 0
[ 72.064514] OMAPFB: Closing fb with plane index 0
[ 72.071319] OMAPFB: ioctl QUERY_MEM
[ 72.072052] OMAPFB: user mmap region start 8084e000, len 1474560, off 8084e000
[ 72.108306] OMAPFB: ioctl QUERY_PLANE
[ 72.108367] OMAPFB: ioctl SETUP_PLANE
[ 72.108367] OMAPFB: omapfb_setup_plane
[ 72.108795] OMAPFB: ioctl QUERY_PLANE
[ 72.108825] OMAPFB: ioctl SETUP_PLANE
[ 72.108856] OMAPFB: omapfb_setup_plane
[ 72.118194] OMAPFB: ioctl QUERY_MEM
[ 72.118225] OMAPFB: ioctl QUERY_PLANE
[ 72.118255] OMAPFB: ioctl GET_CAPS

Have a look at the scripts at http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/angstrom/angstrom-uboot-scripts

regards,

Koen

Have a look at the scripts at http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/angstrom/angstrom-uboot-scripts

regards,

Thanks Koen.
As per the uboot script I have tried

setenv bootargs 'console=tty1 omapfb.mode=dvi:1024x600MR-24@60
root=/dev/mmcblk0p2 rootwait rootfstype=ext3 mem=99M@0x80000000
mem=128M@0x88000000 vram=32M omapfb.vram=0:M,1'

But still there is no change in the vrarm value.
Is any other way to set this VRAM.

omapfb.vram=0:M,1 is not a valid vram setting

Thanks Koen.
As per the uboot script I have tried

setenv bootargs 'console=tty1 omapfb.mode=dvi:1024x600MR-24@60
root=/dev/mmcblk0p2 rootwait rootfstype=ext3 mem=99M@0x80000000
mem=128M@0x88000000 vram=32M omapfb.vram=0:M,1'

omapfb.vram=0:M,1 is not a valid vram setting

Can you pls tell me the right one.

Have a look at the scripts in the link I posted earlier, those show it quite clearly.

Have a look at the scripts in the link I posted earlier, those show it quite clearly.

Yes, I Solved the issue.Thanks .