want to install ruby 1.8 on angstrom beaglebone

would like to install ruby for angstrom beaglebone

uname -aLinux beaglebone 3.2.25 #1 Fri Aug 10 10:33:12 CEST 2012 armv7l GNU/Linux

I downloaded ruby ipk from an angstrom feed but it is for armv7a and some of the dependencies don’t work.

wget http://www.angstrom-distribution.org/feeds/next/ipk/eglibc/armv7a/base/ruby_1.8.7-p302-r2.1.9_armv7a.ipk

opkg install ruby_1.8.7-p302-r2.1.9_armv7a.ipk

Installing ruby (1.8.7-p302-r2.1.9) to root…
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ruby:
  • libgdbm3 * libreadline5 * libtk8.5-0 * libtcl8.5-0 *
  • opkg_install_cmd: Cannot install package ruby.

for instance, I have newer version of libreadline

opkg list-installed | grep libread

libreadline-dev - 6.2-r2
libreadline6 - 6.2-r2

I have been unable to find a ruby that will install.

I tried getting ruby 1.8.7 from source and doing a configure, make, make install
but make fails with a compile error.

So … how to get ruby on my current armv7l distro?

Jerry

Ok. So no one has installed ruby. Then what is best alternative to angstrom so i can install a ruby on it?

There should be nothing stopping you getting it compiled yourself - other than time and a lot of patience. Angstrom at least has the compilers included.

The compile error you don't list should point you in some hopefully helpful direction.

Note things like "i have a newer version of readline" could point to problems too - full version number bumps do not always imply backward compatibility, this depends on the project. tcl/tk for instance is totally incompatible between versions (at least, it was last time i unfortunately came across it, but that was thankfully many years ago).

Regards,
  !Z

Jerry,

I’ve managed to build ruby 1.8.7 package for angstrom. I started with an old, non-working recipe I googled out somewhere and modified it to work with ruby 1.8.7 and recent version of angstrom. I did not submit the recipe to the repository because I did not get networking to work and then I didn’t have time to work on it. Please feel free to upgrade it to ruby 1.9 and push it to angstrom’s git tree.

regards,
j.

ruby-1.8.7_angstrom.tar.gz (4.27 KB)

thanks i will try it. and see what patches there be to get it to 1.9

thought I would let y’all know about this.

ok. ruby 1.8.7 turned out to be problematic.went ahead and installed 1.9.3p286 instead

standard configure/make/make install worked on this one (took about 3 hours).

jerry

Hi. I compiled ruby on the bb a while back. Even though you might get an executable, there are some important optional dependencies like openssl and zlib and readline. In the end i had greatest success using rvm to compile ruby. Remember to read the output of 'rvm dependencies' command (!?!). The mruby project might be a nice option as well depending on what you are doing. It should compile quite easily and require a lot less memory, but will not run any gems :wink:

yeah, I got ruby, and irb.

but get a fatal error when running ruby -d (the debugger)

well I will try rvm and see if I fare better.

thanks

I would expect this to be due to missing libreadline in compilation. Good luck!

yeah. and also libyaml
googled for it, but haven’t found it yet.

Rvm will install what you need...