webmin advice needed

My goal is to run a headless ARM proxy server for my home network. the network has a large number of diferent OS's. Windows, Linux, Android/phones and tablets, Ipads, Bookreaders, printers and so on. I just like the idea of having this little thing that doesn’t take up much space or power doing this simple job of web filtering.

I have a Beaglebone black v6.(http://www.beagleboard.org) Running headless debian 7.2. I can ssh in no problem. I can do normal admin functions i.e. apt-get install and remove files. I can configure with vi no problem. The trouble comes when I have and issue and where to go for advice. For instance, I tried to install webmin last night and all seem well till I tried to log in to the Bone with IE or firefox or chrome form different systems on the network and all came back with the same issue.

When I try to log in I get a message;

You must enter a username and password to login to the Webmin server on

I am using the default user admin name ans password. Username = debian password = debian

This is just a guess. Isn’t it webmin going to need to read the /etc/shadow file for the password?
That file is readable only by the user root and the group shadow. See if there’s anything in the webmin
documentation for what to do about this.

Or, maybe it has its own users and isn’t using the unix users. Dig into the webmin documentation and
see what you can find.

I will. I just needed a place to start. actually, about a 1/2 an hour ago i came up with time and date, which even tho i installed ntb and told it to sync... the system clock was still off by a day. Which means webmin may not like that so i set the time manually with sudo date.. sys clock is now ok but still cant log in with webmin. Alltho it does take much longer to say no joy now.

I also think there is a cert problem. I am not good with certs. Here is some stuff i pulled from the browser.

Browser pointed to =

The site's security certificate is not trusted!
You attempted to reach, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications.
You should not proceed, especially if you have never seen this warning before for this site.

just a reminder.. this is a home network.. no hackers have taken over my BBB..

thats what a self signed cert will do in a browser. That warning is
meant to let you know that, you can then leave the page, or view the
contents of the cert to verify its the one you expect to be served. Make
sure you then save the cert to the browser. Then the next time you go to
the page it will not say anything cause you "accepted" it

I am now thinking i need to add a auth for webmin to PAM. I have never done this before. I ran the setup.pl for webmin and I thought that would have taken care of this. I have a ubuntu 12.04 server running a light desktop(desktop pc). I installed webmin and I didnt have to run any scripts at all … it just worked. I have looked but I cant find a step by step of how to add a auth to the /etc/pam.d/common-auth as far as syntax. if any of you could give me some ideas?

Sorry, I don’t use webmin and do all that grubby sysadmin stuff by hand.

As I understand it webmin has its own user/password file usually in /etc/webmin/miniserv.users

check the FAQ at http://www.webmin.com/faq.html for help.

I am starting to get on that thread as well. I have loaded webmin on some other computers before but only because I was courios to see it. I never actually used it becuase my instructor at the college told us… GUI’s are for the weak". lol… anyway. I have always been more comfortable with a cammad line anyway…

the thing is … for the other systems like the one im typing on now, is a ubuntu 12.04 server. I have webmin installed on it and never had to run a setup script or work with different user/passwords when i installed it… it just worked. so I only had that experence to work with.

thanks fo the help. I have not got it to work yet and am dealing with several other issues as well but I keep good notes and will update here when its working. p.s., forgive the spelling I am quite dyslexic.

GUI’s are for the weak ? Gee, I hope your instructor does not try to create / sell anything resembling a Linux appliance . . .

When working with Linux in a server capacity I do tend to agree though.

I have only been running the BBB headless. I am impressed with how fast it is wtihout graphics. the default install is not bad with a gui… but the cpu and ram are quite busy supporting all of that overhead.

actually he works for ibm’s server support department. I forgot to ask at what level… but he did support while teaching the class from his laptop. I remember he was offten logged into servers that were bought my governments around the world and he could fix just about any issue with ssh. he was quite hi up in his orgization.

Well, my comment was meant to reflect that blanket comments such as these are silly.

I’ve been tinkering with a Linux appliance of sorts using the BBB myself. Granted, the BBB runs headless, and the UI is displayed / partially powered by the client via Nodejs. This is also very fast.