What went wrong

I’ve recently purchased the BBB and over the weekend I went through setting it up. I have to say I’m thoroughly impressed with the setup and the size. I followed the supplied instructions of connecting the device to my computer using the USB cable connecting it from the micro USB port to a port on my laptop, installing the necessary files to communicate with the device. My
issue occurred when I connected the BB in the following manner.

  1. From micro HDMI port to HDMI port on monitor.
  2. Connected the 5V power source into the BB
  3. Connected a USB cable from the USB jack on the BB to my 4 port powered
    USB hub.
  4. Connected the micro USB cable into the 4 port hub.
  5. Inserted wireless keybrd/mouse dongle into the 4 port hub.

When I applied power to the BB within 1 minute of doing so I hear a faint high pitch tone and shortly thereafter I see a spark coming from the board. Based on the setup described what could have gone wrong?

The micro USB port is not for a hub. It is for a PC. Maybe you might want to take a look at the manual.



Yes you’re correct, but I used this port as well due to attempting to figure out why my wireless dongle for keybrd and mouse wasn’t working any longer when it was connected to USB Host connection. When the dongle didn’t work on USB host I then connected it to the USB hub getting the same result. This is when I attempted connecting the USB client connection to the hub and the Hub to the USB Host connect resulting in the arching effect. My thought is it broke my board.

Possibly, depending on what you did. Try starting over and do a basic configuration, only the board and display and see how far you gt.


We’re on the same sheet… I’ve tried restarting the process and the device still isn’t recognized.

You could request an RMA and have it looked at.




You have used both the 5V power source and the mini usb cable. I guess thats why your board got fried up. Use only one of them for the next time.


uh, no . . . both may be hooked up without issue.


That’s what I think David. I’ve got RMA# and will send it in. Hopefully I’ll get a replacement.

This is incorrect. There’s nothing wrong with applying power through USB and VDD_5V (DC plug) at the same time, from the reference manual:

“The selection of either the 5VDC or the USB as the power source is handled internally to the TPS65217C and automatically switches to 5VDC power if both are connected.”