Where is my armv7l file ? ( Building rtl8192cu drivers UNsuccessfully)

Hi

I am trying to follow this guide → http://bogeskov.dk/UsbAccessPoint.html to make my Beaglebone Black act as a Access Point.

So I got to the point where I use the following commands.

`

sudo apt-get install linux-headers-...
git clone https://github.com/dz0ny/rt8192cu.git
cd rt8192cu
make
sudo make install

`

Problem comes when I try and run “make”. I got an error that a file named "build" was missing.

So I tried to install the kernel-headers with this url that is actually the right one for my BeagleBone OS :

https://rcn-ee.net/deb/wheezy-armhf/v3.8.13-bone47/linux-headers-3.8.13-bone47_1.0wheezy_armhf.deb


`Then I ran dpkg -i ```linux-headers-3.8.13-bone47_1.0wheezy_armhf.deb and it looked like it finished.``

So when I go back into the rt8192cu folder I tried running "make" again.
So then I received a different error.

``
`
Makefile:580: /usr/src/linux-headers-3.8.13-bone47/arch/armv7l/Makefile: No such file or directory

make[1]: *** No Rule to make target ’ /usr/src/linux-headers-3.8.13-bone47/arch/armv7l/Makefile '. Stop

`
``

I just want to use my Beaglebone as a Access point

"make ARCH=arm"

Regards,