Where is powervr sgx pvrsrvkm.ko driver?

Hi,

I want to use opengl powervr driver for Qt/embedded. After I opkg install libgles-omap3, it looks successful.
But I can not find where pvrsrvkm.ko is in file system. After I reboot, I try dmesg | grep PVR, nothing appears. Can anyone tell me what I missed?

Thanks,
Kai

I found if I install from Ansgtrom, pvrsrvkm.ko is installed under /lib/module/2.6.37. but my kernel is 2.6.32, not conformable, I need to rebuild it against my kernel. The build is O.K. but after installation, no pvrsrvkm.ko there.
Another issue is I run /etc/init.d/pvr-init start it does’t hit omap3530 branch (or 3730 if I change). instead “No SGX hardware, not starting PVR”. Do I need to tweak Graphics_SDK configuration?

HI Kai,

Did you checked the Driver for pvrsvr is present in the kernel source code?
If present then you Select the component on menuconfig and compile with make module.

with regards,
saminath.

I'm using http://elinux.org/BeagleBoardDebian#SGX_Video_Acceleration
as guide to compile the 3 kernel modules related to PowerVR.

To compile them for 3.8 series I had to patch the source somewhat:
- 1st to make it compile (after some changes about how displays are
linked to omapdss); and
- 2nd to make it work (there were some problems when it tried to
clk_enable SGX_FCK and SGX_ICK; I solved it by clk_prepare'ing before
clk_enable).